1. #1
    Avatar von FabS7AR Neuzugang
    Registriert seit
    Aug 2019
    Beiträge
    4

    Unerklärliche Frame-Drops

    Huhu Foren-Freunde und Ubi-Mitarbeiter,

    ich habe ein kleines Problem, es macht das Game nicht unspielbar, aber es ist ein bisschen nervig. Das Spiel läuft bei mir stabil auf 60 fps @1080p, egal wieviel gerade los ist. Allerdings kommt es zwischendurch immer wieder mal vor, dass die Frames von 60 auf ~30 fallen, was zu einem kleinen Mini-Freeze führt, aber auch nur für eine Sekunde, wenn überhaupt, danach geht es ganz normal weiter. Die zeitlichen Abstände kann ich nicht bestimmen, es fühlt sich total zufällig und fast wie ein Lag an, weil die Spielfigur auch weiter zu laufen scheint. Das passiert allerdings zu verschiedenen Zeitpunkten, das heißt es hat nichts damit zu tun was auf dem Bildschirm gerade passiert. Ich kann auch einfach irgendwo lang laufen und es passiert. Fast so als würde im Hintergrund gerade irgendetwas aktiviert/nachgeladen was die fps in den Keller haut. Diese Probleme habe ich bei keinem meiner anderen Spiele, es scheint zumindest meiner Meinung nach, nicht am System selbst zu liegen.

    Mein System:
    CPU: Ryzen 7 3700X
    RAM: 2X 8GB DDR4 RAM (3200)
    Grafikkarte: NVIDIA GTX 1080 Palit
    Festplatte: 500GB SSD MX500 Crucial (Spiel und Windows laufen auf der gleichen SSD)
    Mainboard: MSI X570 A-Pro
    Windows: Pro 64 Bit

    Temperaturen Ingame:
    Grafikkarte ~80 Grad
    CPU ~60 Grad

    Auslastung: (wird über MSI Afterburner/Rivatuner ausgelesen)
    Grafikkarte: lt. Benchmark durchschnittlich bei 87%
    CPU: chillt meist bei 40%
    VRAM: ~7GB
    RAM: ~11GB

    Grafikeinstellungen: Alles auf ganz hoch, DX12 aktiviert, Vsync aktiviert, keine Framebegrenzung über Ingame-Settings, sondern über Rivatuner, Objekt-Details 75, Neutrales Licht aktiviert, Rest sollte dem Ultra-Preset entsprechen.

    Was ich schon ausgetestet habe und was nicht geholfen hat:
    -Spieldateien verifiziert über Uplay
    -Die Frames mit Rivatuner auf 60 festgelegt
    -OneDrive und Steam deaktiviert (andere Programme laufen nicht im Hintergrund)
    -verschiedene Grafikeinstellungen
    -über Windows den sfc-check ausgeführt und die dism.exe (allerdings wurden keine beschädigten System-Dateien gefunden)

    Der PC ist sehr frisch aufgesetzt, gerade 3-5 Tage alt, an einer vollgemüllten Platte kann es also nicht liegen. Treiber (Chipsatz, Nvidia etc.) sind soweit aktuell und das Bios (7C37vH2) ist auch auf die aktuellste Version geupdatet. Das heißt auch, ich habe KEINERLEI Standard-Einstellungen verändert, lediglich der RAM läuft auf dem integrierten XMP-Profil. Alle Energieoptionen stehen auf dem Normalwert.

    Mir würde es schon helfen, wenn ihr eventuell Ideen einstreuen könntet, um etwas herum zu testen. Es gibt einem einfach ein schlechtes Gefühl, weil man es nicht nachvollziehen kann. Ich will es nicht auf's Spiel selbst schieben, aber andere Spiele laufen komplett problemfrei. Mir fehlen leider die Lösungsansätze.

    Liebe Grüße
    Share this post

  2. #2
    Avatar von Ubi-Trenchcoat Ubisoft Support Staff
    Registriert seit
    Nov 2017
    Beiträge
    608
    Servus FabS7AR!

    Da hast du ja selbst schon einiges gemacht. Eventuell könntest du Mal den MSI Afterburner deinstallieren um das zu testen? Manchmal, wirklich sehr selten, macht der nämlich auch Probleme, aber ansonsten bräuchte ich mehr Infos zu deinem PC.

    Kannst du mir bitte deine DxDiag und MsInfo erstellen und hier innerhalb von [ spoiler] und [/spoiler] den Text einfügen?

    Falls du sie nicht öffentlich posten willst, kannst du mir auch eine DN schreiben.
    Share this post

  3. #3
    Avatar von FabS7AR Neuzugang
    Registriert seit
    Aug 2019
    Beiträge
    4
    Ich habe dir wegen der Dxdiag und Msinfo eine DM geschickt, dass mit dem deaktivieren des MSI Afterburner probiere ich nachher auch mal aus.
    Share this post

  4. #4
    Avatar von Trenty_GER Neuzugang
    Registriert seit
    May 2018
    Beiträge
    4
    Treten diese Probleme nur unter DX12 auf ? ^^



    PS: Da ich selber ein 3700x habe, wie viel Pkt. erreichst du unter Full HD bei max. Settings^^ (Nur eine Frage aus Interesse, kämpfe derzeit selber noch mit meinen System)
    Share this post

  5. #5
    Avatar von FabS7AR Neuzugang
    Registriert seit
    Aug 2019
    Beiträge
    4
    DX 11 habe ich noch nicht lange genug ausprobiert um das sagen zu können, da die Freezes/Hickups (wie auch immer man das nennen möchte) relativ selten bei mir auftreten. Bisher habe ich nur mit Vsync/Framebegrenzung, Objektdetails und solchen Dingen rumgespielt. Denke aber nicht, dass es an den Grafikeinstellungen liegt.

    Allerdings ist mir aufgefallen, dass auch im Benchmark immer an der gleichen Stelle so ein Freeze entsteht, den habe ich jetzt schon zwei mal gemacht und zwei mal an der gleichen Stelle gab's diesen Ruckler.

    Ich habe mich aber gestern abend schon frustriert durch das englische Forum gewühlt, das Problem ist wohl bekannt. Dazu gibt's nen 15-seitigen Thread ohne wirkliche Lösung. Scheint so ein Problem zu sein, dessen man sich bewusst ist, was man aber nicht lösen kann/wird. Da rennen auch Leute mit noch besserem System als ich es habe herum und haben das gleiche Problem.

    Habe in dem Thread auch Videos von anderen Spielern gefunden, die mein Problem 1 zu 1 nachstellen. Ich werde heute abend mal die dort genannten Lösungsmöglichkeiten von anderen Spielern ausprobieren. Ob das hilft? Ich wage es noch zu bezweifeln.

    Im Benchmark erreiche ich nur 5380 Punkte, was aber wohl auch daran liegt, dass er zu 99% aus 60 fps besteht und die FPS an einer Stelle immer extrem fallen. Aber irgendwelche Scores in einem Benchmark sind mir ansich völlig egal, hauptsache das Spiel läuft so wie es soll, aber selbst das ist ja leider nicht der Fall.
    Share this post

  6. #6
    Avatar von Trenty_GER Neuzugang
    Registriert seit
    May 2018
    Beiträge
    4
    Ich und ein ganzes Geschwader das sich mein Freundeskreis nennt, wir alle haben auch diese "Standbilder" eher selten, dennoch fast alle zu gleichen Zeit & alle unter DX12.
    Unter DX11 verlieren wir zwar gut 20% FPS, aber da tritt kein einziger Framedrop/Standbilder auf,probiers einfach mal aus.

    PS: der Benchmarkscore war für mich, weil ich mit anderen Problemen zu kämpfen habe. (Auch im Benchmark tritt ab und zu der Framedrop auf, an der Stelle wo es am Bagger vorbei geht & in richtung Baumkronen) ^^
    Share this post

  7. #7
    Avatar von FabS7AR Neuzugang
    Registriert seit
    Aug 2019
    Beiträge
    4
    Genau an der gleichen Stelle im Benchmark tritt der Framedrop bei mir auch auf, seltsamerweise.

    Ich habe in der Zwischenzeit jetzt mal ein wenig nachgeforscht, du hast recht unter DX11 läuft es definitiv besser, allerdings ist die Performance im Gesamten schlechter. Ist also eher eine unbefriedigende Notlösung.

    Ich habe dann auch wieder zurückgestellt auf DX12 und das Programm "Intelligent Standby List Cleaner" ausprobiert, das verringert die Freezes auf ein Minimum, löst das Problem ansich aber nicht komplett, es kommt meines Erachtens aber definitiv seltener vor. In 4-5 Stunden hatte ich jetzt 2 kleinere Freezes.

    Was mir dabei aufgefallen ist: Die Auslagerungsdatei des RAM verändert sich grundsätzlich nur minimal um wenige MB, wenn diese Freezes auftauchen wächst die Auslagerungsdatei aber direkt und urplötzlich um gute 200MB an und korrigiert sich dann sehr schnell wieder nach hinten.

    Ich weiß nicht was genau das zu bedeuten hat, aber das fällt mir beim Freeze auf und es ist JEDESMAL so. Jedesmal wenn der Freeze auftritt wächst die Auslagerungsdatei direkt um 200MB, während sie ansonsten immer sehr konstant und langsam wächst/fällt. Irgendetwas scheint da mit der Ram-Nutzung nicht zu stimmen, aber ich bin kein Profi, ich kann nur sagen was passiert und hoffen, dass hier jemand etwas damit anfangen kann.
    Share this post