1. #1
    Avatar von Moosi85 Junior Mitglied
    Registriert seit
    Nov 2018
    Beiträge
    30

    bestimmte Sounds werden nicht abgespielt + Übersetzung bei Savegames fehlt

    Hallo,

    Die Soundeffekte vom Gelehrten (Yippie) sowie der Soundeffekt beim Besetzen eines Militärgebäudes werden nicht abgespielt.
    Ebenso der Taubensound beim Abspielen einer neuen Nachricht wird nicht richtig abgespielt. Möglicherweise noch einige andere Soundeffekte. Bitte um Analyse.

    Meine dxdiag:
    https://drive.google.com/file/d/1EJp...ew?usp=sharing

    ------------------------------------

    Nach dem Speichern eines Spieles wird der Name des Spielstandes in English dargestellt.
    Selbiges wenn man auch Laden eines Spielstandes macht.

    ------------------------------------

    manchmal kommt es zu kurzen Rucklern - ob es am Autosave liegt kann ich nur vermuten, da man bei Autosave keine kurze Anzeige erhält alla
    "Spielstand wird gespeichert …" mit einer Sanduhr oder dergleichen.

    Bitte um Analyse der Punkte.
    Ansonsten Super Remake - zocken in 4K klappt gut, Texte sind auch gut lesbar, besser wäre noch die Skalierung einstellbar zu machen, aber das wird die Engine wohl nicht schaffen. :-)
    Share this post

  2. #2
    Avatar von Moosi85 Junior Mitglied
    Registriert seit
    Nov 2018
    Beiträge
    30
    Ich habe dies mal näher untersucht und es liegt wahrscheinlich daran, dass die Sound Dateien schlicht nicht im Verzeichnis DATA\Sound vorhanden sind.

    Es gibt hier Lücken:

    10.wav
    13.wav
    25.wav
    29.wav
    30.wav
    33.wav
    51.wav
    52.wav
    54.wav
    56.wav
    57.wav
    58.wav
    59.wav
    60.wav
    wav files > 65 ?
    Share this post

  3. #3
    Avatar von Moosi85 Junior Mitglied
    Registriert seit
    Nov 2018
    Beiträge
    30
    Es fehlt auch der Sound, wenn ein gegnerischer Soldat besiegt wurde.
    Share this post

  4. #4
    Avatar von Ubi-Barbalatu Community Developer
    Registriert seit
    Aug 2014
    Beiträge
    3.296
    Hallo,

    Danke dir. Habe ich einmal aufgenommen.

    Grüße,
    Barbalatu
    Share this post

  5. #5
    Avatar von Matthiasblack Neuzugang
    Registriert seit
    Dec 2018
    Beiträge
    1
    Gibt es bereits neuere Informationen zu den fehlenden Sounds ?
     1 people found this helpful
    Share this post

  6. #6
    Avatar von Atlanta31415111 Neuzugang
    Registriert seit
    Sep 2018
    Beiträge
    4

    bestimmte Sounds werden nicht abgespielt + Übersetzung bei Savegames fehlt

    Es ist nun 4 Monate her, dass der Fehler mit den fehlerhaften Sounds gemeldet wurde und es ist immer noch nichts passiert. Ich finde es wirklich schade, dass Ubisoft hier nichts mehr unternimmt und keine Status-Updates liefert, so macht das Spielen wirklich keinen Spaß.
    Share this post

  7. #7
    Avatar von Ubi-Barbalatu Community Developer
    Registriert seit
    Aug 2014
    Beiträge
    3.296
    Das Thema liegt weiterhin beim Entwickler-Team auf dem Tisch hat aber eine niedrige Priorität.
    Share this post

  8. #8
    Avatar von daish0 Neuzugang
    Registriert seit
    Jan 2006
    Beiträge
    22
    Hi,

    ich habe gestern ein wenig mit der gold edition von GoG herumgespielt und via LST entpacker tool von den RTTR Machern die .WAV sounds entpackt.
    Leider musste ich diese noch manuell via Hex-Editor editieren da das Tool leider keinen ordentlichen WAVE header schreibt.

    Wen es technisch interessiert:

    Ein typisches WAV file generiert via dem lstpacker.exe tool generiert einen Header wie z.B.:
    (die fragezeichen werden in einem hex editor üblicherweise anders, z.B. als Punkte, angezeigt)

    Code:
    03 27 00 00 52 49 46 46 FB 26 00 00 57 41 56 45    '��RIFFû&��WAVE
    66 6D 74 20 10 00 00 00 01 00 01 00 44 AC 00 00    fmt �����D¬��
    44 AC 00 00 02 00 10 00 64 61 74 61 D7 26 00 00    D¬����data×&��
    7F 80 7F 81 80 80 80 80 80 80 80 80 80 80 80 80    €€€€€€€€€€€€€
    Um die WAV files zu reparieren musste ich die ersten 4 bytes entfernen (ein WAVE header beginnt mit "RIFF", siehe http://soundfile.sapp.org/doc/WaveFormat/),
    die Angaben zu Sample-, Byte und Bit/Sample-Rate passen ebenfalls nicht und würden nur ein file ergeben das "rauscht".

    Repariert (nach Vorgaben von http://settlers2.net/documentation/lst-file-format/, "WAV files are 8-bit mono 11025 Hz PCM files without WAV header.") sähe der neue Header dann so aus:

    Code:
    52 49 46 46 FB 26 00 00 57 41 56 45 66 6D 74 20    RIFFû&��WAVEfmt 
    10 00 00 00 01 00 01 00 11 2B 00 00 11 2B 00 00    �����+��+��
    01 00 08 00 64 61 74 61 D7 26 00 00 7F 80 7F 81    ��data×&��€
    80 80 80 80 80 80 80 80 80 80 80 80 80 80 80 80    €€€€€€€€€€€€€€€€
    Nur soviel dazu wie man die Original-Sounds wieder bekommt sollte man bereits eine andere Siedler 2 Version sein Eigen nennen.
    Nebenbei ... manche der vorhandenen Sound-Files klingen anders als die Originale - ich vermute das ist so gewollt? (sehr stark merkte ich das z.B. bei der Eule)


    Wie auch immer, Ubi's Siedler 2 History Edition hat die Sound-Fx-Files umbenannt (die lstpacker.exe erzeugt .WAV Dateien mit der Bezeichnung startend mit 51.wav).
    In der History-Edition beginnen diese mit 0001.wav. Meine Vermutung ist dass einfach 50 abgezogen wurde quer durch die Bank (sieht zumindest auf den ersten Blick so aus).

    D.h. die 51.wav aus der lstpacker.exe wäre dann die 0001.wav.

    Ja, manche Files fehlen in der Liste. Es gibt z.B. keine 0010.wav, die gab es aber auch im Original schon nicht.
    WAV files die in der History Edition fehlen sind lt. Merge beider Ordner (Name bereits angepasst für History Edition, Original Name wäre demnach Nummer +50):

    0051.wav (im Original also 101.wav) - klingt wie Schmiedehammer oder Schwerschlag
    0052.wav - klingt wie das Klopfen auf einen Stein
    0054.wav - klingt wie der Sterbe-Schrei von Soldaten
    0057.wav - Yippie der Geologen! (das war einer der ersten Sounds die mir abgegangen sind)
    0058.wav - kein Sound (quasi leer, auch lt. Hex-Editor)
    0059.wav - kurzer Ton (schwer zu beschreiben, hört sich wie ein falscher Klick aus einer Windows-Theme an)
    0060.wav - Fanfare, ev. "Mission geschafft" Sound?

    Die History Edition hat allerdings noch die WAV files:
    00SCHWE1.WAV und 00SCHWE2.WAV, nicht sicher wo diese eingesetzt werden.



    Jetzt das Gute: Man kann die fehlenden exportieren und reparierten Sounds aus dem Original einfach mit dem geänderten Dateinamen 0051.wav etc. in den thesettlers2\DATA\sound Ordner kopieren und diese (zumindest das "Yippie!" klappte in einem kurzen Test) werden dann auch abgespielt wie es scheint.

    Das schlechte: Ich kann die Sounds nicht einfach irgendwo als ZIP uploaden da ich mich sonst angreifbar mache wegen Urheberrecht etc., daher lasse ich das.

    Aber meiner Meinung nach sollte ein Patch oder zumindest eine Aussage ala "wir wollten diese Sounds nicht im Spiel haben, deswegen haben wir sie weggelassen" (wobei ich das für die Sieges-Fanfare oder Sterbe-Sounds nicht nachvollziehen kann > deswegen denke ich die wurden einfach vergessen beim Kopieren) mittlerweile vorhanden sein.
    Ich habe das Ganze jetzt ohne Vorwissen von S2 und deren Datenstruktur in einer halben Stunde zusammengebastelt ... die Leute hier warten seit Monate auf einen Patch der vermutlich nie kommen wird weil alle Resourcen abgezogen wurden -_-



    lg,
    daisho
    Share this post