PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Möchte jemand "Max TC" mit einem Tastendruck?



Mittelwaechter
12-04-08, 19:57
Schon wunden Zeigefinger vom ständigen "NumPad +" drücken? Der Nord-Ostsee-Kanal kann einen doch in die Verzweiflung treiben.

Unter (C:\Programme)\Ubisoft\SilentHunterIII\data\Cfg die Commands_de.cfg öffnen (mit Notepad)

Unter [Cmd5] folgende Zeile anhängen (von hier kopieren und einfügen!)

Key1=0x6A,R,"Npad *"

und abspeichern.

Jetzt könnt ihr mit "NumPad *" die TC mit einem Tastendruck auf max stellen.

Wie immer: Sicherungskopie anfertigen!


Gute Jagd!

Mittelwaechter
12-04-08, 19:57
Schon wunden Zeigefinger vom ständigen "NumPad +" drücken? Der Nord-Ostsee-Kanal kann einen doch in die Verzweiflung treiben.

Unter (C:\Programme)\Ubisoft\SilentHunterIII\data\Cfg die Commands_de.cfg öffnen (mit Notepad)

Unter [Cmd5] folgende Zeile anhängen (von hier kopieren und einfügen!)

Key1=0x6A,R,"Npad *"

und abspeichern.

Jetzt könnt ihr mit "NumPad *" die TC mit einem Tastendruck auf max stellen.

Wie immer: Sicherungskopie anfertigen!


Gute Jagd!

Bertl01
13-04-08, 08:36
Hallo Mittelwächter,

danke für diese klasse Idee!

gute Jagd,

Bertl

Soni2
16-04-08, 08:47
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Zitat von Mittelwaechter:
Schon wunden Zeigefinger vom ständigen "NumPad +" drücken? Der Nord-Ostsee-Kanal kann einen doch in die Verzweiflung treiben.

Unter (C:\Programme)\Ubisoft\SilentHunterIII\data\Cfg die Commands_de.cfg öffnen (mit Notepad)

Unter [Cmd5] folgende Zeile anhängen (von hier kopieren und einfügen!)

Key1=0x6A,R,"Npad *"

und abspeichern.

Jetzt könnt ihr mit "NumPad *" die TC mit einem Tastendruck auf max stellen.

Wie immer: Sicherungskopie anfertigen!


Gute Jagd! </div></BLOCKQUOTE>

Heyho,

das ist ja eine tolle Sache. Da fallen mir gleich noch mehr ein. Etwa per Tastendruck automatisch die Flak besetzen mit Modus "Feuer frei"
Oder per Tastendruck Tiefe Unter Kiel ansagen, und, und, und.

Wie bekomme ich eigentlich heraus, welche Taste welche Wert hat? Also woher weiß ich, daß "NumPad *" nun 0x6A ist?

DerZombie
16-04-08, 11:46
Hol dir einfach Setkey, dann ist das alles kein Prob. Link findest bestimmt im Forum oder Friedls Hilfepage.

Da mußt dann nur für z.b. AA besetzen auswählen und dann angeben welche Taste es sein soll, den Rest macht das Miniprogramm http://forums.ubi.com/infopop/emoticons/icon_smile.gif

Mittelwaechter
16-04-08, 12:20
Mit SetKeys kann man alle vorhandenen Befehle an eigene Tasten binden, aber man kann - soviel ich weiß - keine neuen Befehle generieren.

Oder hast du in deiner commands.cfg den Befehl die TC auf max zu stellen?

Virtuelle Keycodes gibt es zum Beispiel hier (http://www.help-guide.de/win_virtual_key.htm).

DerZombie
16-04-08, 12:34
Jo das stimmt aber die die Soni2 aufführte sind ja orginal vorhanden und somit mit Setkey umsetzbar http://forums.ubi.com/infopop/emoticons/icon_wink.gif

KretschmerU99
16-04-08, 13:14
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Zitat von Mittelwaechter:
Virtuelle Keycodes gibt es zum Beispiel hier (http://www.help-guide.de/win_virtual_key.htm). </div></BLOCKQUOTE>

Coole Sache - das habe ich schon immer mal gesucht . . . http://forums.ubi.com/images/smilies/11.gif

Vielen Dank, Mittelwächter!

@Zombie
Recht haste! Leichen sollen im Keller bleiben!

Soni2
16-04-08, 13:50
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Zitat von DerZombie:
Jo das stimmt aber die die Soni2 aufführte sind ja orginal vorhanden und somit mit Setkey umsetzbar http://forums.ubi.com/infopop/emoticons/icon_wink.gif </div></BLOCKQUOTE>

Jep. Hatte mal versucht mir ein Makro zu basteln, welches mir die Flakcrew auf die Brücke holt, Feuer frei befiehlt und auf anfliegende Bomber schießen läßt. Hat aber nicht ganz so geklappt, wie ich mir das vorgestellt habe.

U521_8
16-04-08, 14:14
Hi,
da wir gerade bei der commands_de.cfg und Tastenbelegung sind, hab ich dazu mal eine Frage:
Wenn die Taste "Q" gedrückt wird erscheint unten im Schriftfeld z.B. "Mündungsklappe für Rohr 1 wird geöffnet!".
Nach drücken der Taste "W" wird die Mündungsklappe 1 wieder geschlossen. Nur erscheint im Schriftfeld "Mündungsklappe für Rohr 1 wird geschlossen!" leider nicht. http://forums.ubi.com/infopop/emoticons/icon_frown.gif
Kann man das aktivieren oder ist dies hardcodet http://forums.ubi.com/images/smilies/35.gif

MfG plexman

Mittelwaechter
03-05-08, 05:00
Ja, das kann man aktivieren! http://forums.ubi.com/images/smilies/16x16_smiley-surprised.gif

Im Stammverzeichnis \Menu\de_menu.txt öffnen und den String &lt; 4529=Mündungsklappe wird geschlossen, Herr Kaleun! &gt; anlegen/abspeichern.

Leider klappt es mit der Rohrnummer nicht, aber besser wie nix!

Jetzt in \data\commands_de.cfg (mit notepad/editor öffnen) den Befehl [Cmd311] suchen. Hier den eben erstellten String als Verweis anlegen.

So:

[Cmd311]
Name=Close_sel_torpedo_tube
Ctxt=1
Str=4529
Key0=0x57,C,"W"

Im Key0 das "C" zwischen die Kommata setzen - auch im Befehl [Cmd310] direkt darüber! Jetzt bekommt man auch ein "Jawohl, Herr Kaleun!" als akustische Bestätigung.

Speichern!

Ergebnis:
&lt;&lt;Q&gt;&gt; = "Jawohl, Herr Kaleun!" + Anzeige &lt;Mündungsklappe Rohr X wird geöffnet&gt;

&lt;&lt;W&gt;&gt; = "Jawohl, Herr Kaleun!" + Anzeige &lt;Mündungsklappe wird geschlossen, Herr Kaleun!&gt;


"Verdammt nochmal! Ich will anständige Meldungen!" http://forums.ubi.com/infopop/emoticons/icon_biggrin.gif


Edit: Wie immer - bacdafucup!

U521_8
05-05-08, 11:29
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Zitat von Mittelwaechter:
Ja, das kann man aktivieren! http://forums.ubi.com/images/smilies/16x16_smiley-surprised.gif

Im Stammverzeichnis \Menu\de_menu.txt öffnen und den String &lt; 4529=Mündungsklappe wird geschlossen, Herr Kaleun! &gt; anlegen/abspeichern.

Leider klappt es mit der Rohrnummer nicht, aber besser wie nix!

Jetzt in \data\commands_de.cfg (mit notepad/editor öffnen) den Befehl [Cmd311] suchen. Hier den eben erstellten String als Verweis anlegen.

So:

[Cmd311]
Name=Close_sel_torpedo_tube
Ctxt=1
Str=4529
Key0=0x57,C,"W"

Im Key0 das "C" zwischen die Kommata setzen - auch im Befehl [Cmd310] direkt darüber! Jetzt bekommt man auch ein "Jawohl, Herr Kaleun!" als akustische Bestätigung.

Speichern!

Ergebnis:
&lt;&lt;Q&gt;&gt; = "Jawohl, Herr Kaleun!" + Anzeige &lt;Mündungsklappe Rohr X wird geöffnet&gt;

&lt;&lt;W&gt;&gt; = "Jawohl, Herr Kaleun!" + Anzeige &lt;Mündungsklappe wird geschlossen, Herr Kaleun!&gt;


"Verdammt nochmal! Ich will anständige Meldungen!" http://forums.ubi.com/infopop/emoticons/icon_biggrin.gif


Edit: Wie immer - bacdafucup! </div></BLOCKQUOTE>

Danke Mittelwaechter, hab es eingebaut und funzt http://forums.ubi.com/infopop/emoticons/icon_smile.gif

MfG plexman

KretschmerU99
05-05-08, 11:47
Jaaa, das fehlt mir auch.

Dankeschön!

DarkMephisto
05-05-08, 12:21
auch n fettes Danke von mir, endlich keine wunden Finger mehr und eine kaputte + Taste http://forums.ubi.com/infopop/emoticons/icon_biggrin.gif

Mittelwaechter
05-05-08, 16:11
Bitte sehr, gerne doch! http://forums.ubi.com/infopop/emoticons/icon_smile.gif

Wenn wir schon so schön am personalisieren der commands.cfg sind - wie wär's mit einer Befehlskette?

Soni2 wünscht sich: "Flak besetzen! über große Distanz auf anfliegende Bomber und Jäger zielen! Feuer frei!"

Geht schon!
Nur ein Tastendruck bzw. Shift + Taste?

Ich habe die "A" Taste gewählt, liegt schön nah bei Shift.
Einfach &lt; Key0=0x41,Cs,"shift+A";Combo &gt; unter die entsprechenden [Cmdxxx] kopieren.

Soll so aussehen:

[Cmd419]
Name=AAGuns_Fire_at_will
Ctxt=1
MnID=0x3F180006
Str=1063
Key0=0x41,Cs,"shift+A";Combo

[Cmd423]
Name=AAGuns_Long_range
Ctxt=1
MnID=0x3F18000A
Str=1067
Key0=0x41,Cs,"shift+A";Combo

[Cmd426]
Name=AAGuns_Aim_any
Ctxt=1
MnID=0x3F18000D
Str=1070
Key0=0x41,Cs,"shift+A";Combo

[Cmd427]
Name=AAGuns_Closing_targets
Ctxt=1
MnID=0x3F18000E
Str=1071
Key0=0x41,Cs,"shift+A";Combo

[Cmd431]
Name=Man_the_flak_gun
Ctxt=1
MnID=0x3F2D0003
Str=2945
Key0=0x41,Cs,"shift+A";Combo

Nach einem "Flugzeug gesichtet!" bricht jetzt mit "Shift+A" die Hölle los...

Wen die falsche Reihenfolge stöt, der tausche Cmd419 mit Cmd431 - dann wird erst die Flak besetzt und den Abschluss des Befehles bildet das "Feuer frei!"
Die commands.cfg wird immer von oben nach unten abgearbeitet!

Sicherungskopie nicht vergessen!

Grüße!

KretschmerU99
15-05-08, 13:32
Hmmm, das probiere ich mal aus

So, habe mal editiert - aber es klappt nicht so optimal:
Hier mein Block nach deinen Daten


[Cmd419]
Name=Man_the_flak_gun
Ctxt=1
MnID=0x3F2D0003
Str=2945
Key0=0x41,Cs,"shift+A";Combo

[Cmd420]
Name=AAGuns_Hold_fire
Ctxt=1
MnID=0x3F180007
Str=1064

[Cmd421]
Name=AAGuns_Short_range
Ctxt=1
MnID=0x3F180008
Str=1065

[Cmd422]
Name=AAGuns_Medium_range
Ctxt=1
MnID=0x3F180009
Str=1066

[Cmd423]
Name=AAGuns_Long_range
Ctxt=1
MnID=0x3F18000A
Str=1067
Key0=0x41,Cs,"shift+A";Combo

[Cmd424]
Name=AAGuns_Aim_fighters
Ctxt=1
MnID=0x3F18000B
Str=1068

[Cmd425]
Name=AAGuns_Aim_bombers
Ctxt=1
MnID=0x3F18000C
Str=1069

[Cmd426]
Name=AAGuns_Aim_any
Ctxt=1
MnID=0x3F18000D
Str=1070
Key0=0x41,Cs,"shift+A";Combo

[Cmd427]
Name=AAGuns_Closing_targets
Ctxt=1
MnID=0x3F18000E
Str=1071
Key0=0x41,Cs,"shift+A";Combo

[Cmd428]
Name=AAGuns_Any_targets
Ctxt=1
MnID=0x3F18000F
Str=1072

[Cmd429]
Name=AAGuns_Update_target
Ctxt=1

[Cmd430]
Name=Man_the_deck_gun
Ctxt=1
MnID=0x3F2D0002
Str=2944

[Cmd431]
Name=AAGuns_Fire_at_will
Ctxt=1
MnID=0x3F180006
Str=1063
Key0=0x41,Cs,"shift+A";Combo

Die Flak wird besetzt - aber die weitern Befehle klappen nicht(habe die Reihenfolge geändert, wie du beschrieben "Feuer Frei" als Letztes. Der rest bleibt Standart, wie vom Spiel vorgegeben - auch Feuer frei wird nicht aktiviert. Was könnte ich machen?

http://img137.imageshack.us/img137/780/tastaturlm9.jpg (http://imageshack.us)
http://img137.imageshack.us/img137/780/tastaturlm9.41c63383f1.jpg (http://g.imageshack.us/g.php?h=137&i=tastaturlm9.jpg)


Fette Beute

Mittelwaechter
16-05-08, 05:30
Hallo KretschmerU99,

wenn ich das richtig sehe, hast du alles korrekt abgeändert. Nun drück' mal im Crew-Bildschirm &lt;Shift+A&gt; ohne die Flak anzuwählen. Sobald der WO auf der Brücke ist, sollte das in jeder Situation sofort funktionieren.

Warst du vor der Änderung im Hafen? Gegebenenfalls probier es mit einer neuen Testkarriere.

Geht schon!

http://forums.ubi.com/infopop/emoticons/icon_smile.gif

KretschmerU99
16-05-08, 07:48
Na dann wollen wir mal . . . Hatte es anfangs auf FF editiert(Blöcke in der comdt.cfg). Das obrige Resultat.

Jetzt war ich im Hafen, per sgme deaktiviert, Spiel verlassen und dann wieder aktiviert. Ausgelaufen, Test Negativ. Es bleibt dabei, die Jungs gehen in die Flakstellung, auf weiter Befehle passiert nix

http://img211.imagevenue.com/loc25/th_41806_Flak_1_123_25lo.jpg (http://img211.imagevenue.com/img.php?image=41806_Flak_1_123_25lo.jpg)http://img210.imagevenue.com/loc152/th_41807_Flak_2_123_152lo.jpg (http://img210.imagevenue.com/img.php?image=41807_Flak_2_123_152lo.jpg)http://img215.imagevenue.com/loc202/th_41809_Flak_3_123_202lo.jpg (http://img215.imagevenue.com/img.php?image=41809_Flak_3_123_202lo.jpg)

Vielleicht liegts doch an dem Vertauschen der Blöcke zwecks "Feuer Frei"????

Noch ein kleines anderes Anliegen. Spiele mit LSH 3.1 und vermisse die SlideInstrumente des LIVerbrauch, Batterielevel, Preßluft, Co2). Ich suche den Grundmod-falls den noch jemand hat- WENN nicht, würde ich gerne die Instrumente per Taste vorholen - da das Anklicken Offizier(LI)\Meldungen zu umständlich scheint.siehe Bild!
Kann man den Befehl "Meldungen" irgenwie per Taste aktivieren???
http://img174.imagevenue.com/loc651/th_41996_Instrumente_123_651lo.jpg (http://img174.imagevenue.com/img.php?image=41996_Instrumente_123_651lo.jpg)

Mal sehen, was du da anbieten kannst http://forums.ubi.com/infopop/emoticons/icon_biggrin.gif
Danke vorab schon mal!

Fette Beute!
U99

Mittelwaechter
16-05-08, 10:51
Hallo KretschmerU99,

was ist ein Grundmod-flas?

Änderungen immer nur dann aufspielen, wenn dein Eimer im Hafen ankert, Herr Kaleun!

Das Vertauschen der Blöcke sollte keinen Einfluss haben.
Per Mausklick funktionieren alle Befehle des WO?

Möglicherweise hat einer deiner Mods die Menu1024x768.ini verändert, und die MnID's stimmen nicht mehr? Vergleiche deine Änderung in der Commands_de.cfg nochmal mit deinem Backup der ürsprünglichen Datei. Hast du nur die Key-Zeile einkopiert, oder einfach die gesamten Textblöcke?

Zu deinem Wunsch: theoretisch sollte das klappen, indem man einen neuen Befehl generiert, die ItemID aus der 1024x768.ini verknüpft und den Befehl entsprechend der INI benennt. Das ist einfach mal eine wilde Vermutung - mal sehen was ich da machen kann. Allerdings könnte das möglicherweise nicht auf deine Dateien übertragbar sein - wegen der Veränderungen durch deine aktuellen Mods. Du müsstest dann selber nach den korrekten Verknüpfungen suchen...

KretschmerU99
17-05-08, 01:42
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Zitat von Mittelwaechter:
Hallo KretschmerU99,

was ist ein Grundmod-flas?

Änderungen immer nur dann aufspielen, wenn dein Eimer im Hafen ankert, Herr Kaleun!

Das Vertauschen der Blöcke sollte keinen Einfluss haben.
Per Mausklick funktionieren alle Befehle des WO?

Möglicherweise hat einer deiner Mods die Menu1024x768.ini verändert, und die MnID's stimmen nicht mehr? Vergleiche deine Änderung in der Commands_de.cfg nochmal mit deinem Backup der ürsprünglichen Datei. Hast du nur die Key-Zeile einkopiert, oder einfach die gesamten Textblöcke?

Zu deinem Wunsch: theoretisch sollte das klappen, indem man einen neuen Befehl generiert, die ItemID aus der 1024x768.ini verknüpft und den Befehl entsprechend der INI benennt. Das ist einfach mal eine wilde Vermutung - mal sehen was ich da machen kann. Allerdings könnte das möglicherweise nicht auf deine Dateien übertragbar sein - wegen der Veränderungen durch deine aktuellen Mods. Du müsstest dann selber nach den korrekten Verknüpfungen suchen... </div></BLOCKQUOTE>


Hallo Mittelwächter!

Grundmod , falls den noch jemand hat - so sollte das heißen, ein Tippfehler von mir Sorry

Per Mausklick sollten die Befehle funktionieren, da bin ich mir sicher. Die menu.ini ist natürlich durch LSH 3.1 verändert, aber mit MnID kenne ich mich ja überhaut nicht aus. Selbst habe ich ja die Tastatur angepaßt(W=Wetterbericht, &lt; Tiefendurchsage unter Kiel,b =Täuschköper, TC auf max, 0=Pause usw.) Das klappte auch ganz gut. Nur die Combie Sachen(mich stöt das automatische Laden nach auftauchen, daher wollte ich Batterieladen nur ab Fahrstufe 1-2manuell, sobald man mit Stufe 3/4/5 fährt die Ladung unterbrochen wird - funktioniert jetzt bei mir ab 4/5(keine Ladung der Batterie, also auftauchen Ladung an kurzFS 4 od. 5=Ladung unterbrochen=mehr Geschwindigkeit) - wobei das wieder nur geht, wenn ich per "Tastatur" auf 4/5 klicke(deaktivierung der Batterieladung) und geht nicht am Telegraphen - da läd sie weiter. Habe probiert auch die Stufe 3 mit einzubeziehen - ging nicht. Friedl hatte mir da mal geschrieben, daß SH3 vielleicht Probleme bekommt, wenn man Mehrfachbelegungen auf eine Taste legt(mehr als 3 z.B.). Das würde sich hier bestätigen.
Ich habe die ganzen Textblöcke reinkopiert - also werde ich mal die alten mit Winmerge und deinen Daten nochmals gegenprüfen . . . http://forums.ubi.com/infopop/emoticons/icon_smile.gif Vielleicht liegt da ja ein Fehler bei mir . . .
Bitte nehme dich nicht meines Wunsches an, der Aufwand wäre nicht gerechtfertigt - ich versuche über Tankerschreck und Bertl01 die Instrumente slidefähig einzubauen, Tipps haben sie mir gegeben . . . mal sehen.
Aber wenn du gerne etwas probieren willst . . . ich hätte da was(hatte ich schon mal vor Monaten im Forum gepostet).

Ein früheres Problem ist wohl ähnlich: per Knopfdruck den Wachhabenden Offizier auf die Brücke nach Auftauchen "zu holen". Gerade in späteren Kriegsjahren, wo man ständig taucht und hoch geht wäre das doch sehr praktisch - nicht immer in dem Mannschaftsbildschirm zu wechseln - ABER das soll wohl programmtechnisch nicht möglich sein.

Also Danke für dein Bemühen, ich probiere den Vergleich und melde mich wieder. Hoffe mein obere Artikel mit der Laderei ist in etwa nachzuvollziehen(mein Ziel, nach Unterwasserangriff zB am Geleit, Auftauchen und mit Max Geschwindigkeit hinterher jagen, Batterie später, wenns mir "paßt" nachladen . . .)
Ah, da fällt mir nochein Programm von Friedl's Hilfsseite ein, da konnte man die Tastatur ändern - allerdings konnte ich die Belegung nicht abspeichern - warum auch immer . . .

Fette Beute!
MfG U99

Mittelwaechter
17-05-08, 05:49
Hallo KretschmerU99,

die Fahrstufe 3 wird automatisch gewählt, wenn du einen Kurs aus dem Stillstand setzt. Vielleicht liegt es eher daran, als dass SH3 nicht mit mehr als drei Belegungen pro Taste klar kommt.

Ich hab da einen Tastaturbefehl "Normaler Antrieb" - wenn ich auftauche und direkt Speed brauche, dann drück ich &lt;Shift+Y&gt; und ab geht die Post. Vielleicht auch eine Option für dich?

[Cmd151]
Name=Propulsion_standard
Ctxt=1
MnID=0x3F0F0001
Str=1001
Key0=0x59,Cs,"shift+Y"

Mit der Verbrauchsanzeige bin ich nicht recht weiter gekommen - wenn du es nicht mehr brauchst, ist das zwar witzlos, aber irgendwie fühle ich mich herausgefordert.

Den WO per Taste auf die Brücke holen? Ist das überhaupt sinnvoll? Der Zwang, den Crew-Bildschirm zu checken ist beabsichtigt, um Probleme mit der Crew zu vermeiden. Muss der WO dann nicht auch einen festen Schlafplatz haben? Hhm... obwohl...

http://www.ubisoft.de/smileys/read.gif

Edit: Habe ich das richtig verstanden, wenn du die "3", "4" und "5" mit der Standard Propulsion verknüpfst, klappt das mit der "3" nicht?

Sieht dein Command Block so aus?

[Cmd151]
Name=Propulsion_standard
Ctxt=1
MnID=0x3F0F0001
Str=1001
Key0=0x33,C,"3"
Key1=0x34,C,"4"
Key2=0x35,C,"5"

Sollte perfekt nach deinen Wünschen funktionieren...

KretschmerU99
17-05-08, 13:30
Tja, mal sehen - ist schon länger her, wo ich das alles mal ausgetestet hatte - leider fehlt momentan die Zeit zum doktern . . .

So wie oben beschrieben, läufts obwohl meine Zeile so aussieht:
Sah so aus

[Cmd151]
Name=Propulsion_standard
Ctxt=1
MnID=0x3F0F0001
Str=1001
Key0=0x34,,"4"
Key0=0x35,,"5"

Probiere grad deine Version + überprüfte und eingefügte Flakbefehle(keinen Fehler festgestellt):

[Cmd151]
Name=Propulsion_standard
Ctxt=1
MnID=0x3F0F0001
Str=1001
Key0=0x33,C,"3"
Key1=0x34,C,"4"
Key2=0x35,C,"5"

Folgt . . .
OK da hast du mich eines besseren belehrt - nach deiner Version - fahre ich jetzt auch mit Stufe 3 "Vollgas"
Wie müßte ich den den Block ändern, wenn ich bei max Geschwindigkeit ohne Laden - Taste 1 oder 2 drücke, um "automatisch " wieder mit Fahrstufe 1-2 laden kann ohne manuell einzugreifen?

[Cmd152]
Name=Propulsion_recharge
Ctxt=1
MnID=0x3F0F0002

evl das einfügen
Key0=0x31,C,"1"
Key1=0x32,C,"2" ???

Flak fehler bleibt bestehen, jetzt reagiert shift+A gar nicht mehr - es ist nix passiert.

meine Blöcke mit LSH 3.1 eben nach Vergleich getestet allerdings auf einem II-A Boot

[Cmd419]
Name=Man_the_flak_gun
Ctxt=1
MnID=0x3F2D0003
Str=2945
Key0=0x41,Cs,"shift+A";Combo

[Cmd420]
Name=AAGuns_Hold_fire
Ctxt=1
MnID=0x3F180007
Str=1064

[Cmd421]
Name=AAGuns_Short_range
Ctxt=1
MnID=0x3F180008
Str=1065

[Cmd422]
Name=AAGuns_Medium_range
Ctxt=1
MnID=0x3F180009
Str=1066

[Cmd423]
Name=AAGuns_Long_range
Ctxt=1
MnID=0x3F18000A
Str=1067
Key0=0x41,Cs,"shift+A";Combo

[Cmd424]
Name=AAGuns_Aim_fighters
Ctxt=1
MnID=0x3F18000B
Str=1068

[Cmd425]
Name=AAGuns_Aim_bombers
Ctxt=1
MnID=0x3F18000C
Str=1069

[Cmd426]
Name=AAGuns_Aim_any
Ctxt=1
MnID=0x3F18000D
Str=1070
Key0=0x41,Cs,"shift+A";Combo

[Cmd427]
Name=AAGuns_Closing_targets
Ctxt=1
MnID=0x3F18000E
Str=1071
Key0=0x41,Cs,"shift+A";Combo

[Cmd428]
Name=AAGuns_Any_targets
Ctxt=1
MnID=0x3F18000F
Str=1072

[Cmd429]
Name=AAGuns_Update_target
Ctxt=1

[Cmd430]
Name=Man_the_deck_gun
Ctxt=1
MnID=0x3F2D0002
Str=2944

[Cmd431]
Name=AAGuns_Fire_at_will
Ctxt=1
MnID=0x3F180006
Str=1063
Key0=0x41,Cs,"shift+A";Combo

Es ist zum Mäuse melken, wenn man weiß, das es gehen kann aber nicht funktioniert . . .

MfG
Kretschmer

Mittelwaechter
17-05-08, 15:07
Hallo KretschmerU99,

im ersten Block hast du zweimal Key0 vergeben - das wird nicht klappen.

Dein Vorschlag für Stufe 1 und 2 mit Batterie laden ist genau richtig. Wenn die Batterie schon geladen ist, kommt vielleicht eine Meldung...

Die Flak-Combo geht bei jedem Boot - wenn es eine Flak hat. Das IIa wird erstmal ohne Flak ausgeliefert. &lt;=!! Da gibt's dann auch nix zu besetzen...

Also ich kann bei deiner Befehlskette für die Flak keinen Fehler finden.
Key0(NULL)=0(NULL)x41,Cs,blablabla ist korrekt, die MnID's sind auch mit meinen identisch. Eigentlich müsste es ohne Probleme laufen.
Kannst du das mal auf einer sauberen Installation testen? Es geht auf alle Fälle mit Stock 1.4b und mit GWX2.0. Möglicherweise funkt doch irgend einer deiner Mods dazwischen. Kann ich zwar nicht nachvollziehen, aber da kann ich dir kaum helfen. http://forums.ubi.com/images/smilies/cry.gif

Edit: hier meine Cmd-Blöcke 419 bis 431 zum kopieren

[Cmd419]
Name=Man_the_flak_gun
Ctxt=1
MnID=0x3F2D0003
Str=2945
Key0=0x41,Cs,"shift+A";Flak-Combo

;Name=AAGuns_Fire_at_will
;Ctxt=1
;MnID=0x3F180006
;Str=1063
;Key0=0x41,Cs,"shift+A";Flak-Combo

[Cmd420]
Name=AAGuns_Hold_fire
Ctxt=1
MnID=0x3F180007
Str=1064

[Cmd421]
Name=AAGuns_Short_range
Ctxt=1
MnID=0x3F180008
Str=1065

[Cmd422]
Name=AAGuns_Medium_range
Ctxt=1
MnID=0x3F180009
Str=1066

[Cmd423]
Name=AAGuns_Long_range
Ctxt=1
MnID=0x3F18000A
Str=1067
Key0=0x41,Cs,"shift+A";Flak-Combo

[Cmd424]
Name=AAGuns_Aim_fighters
Ctxt=1
MnID=0x3F18000B
Str=1068

[Cmd425]
Name=AAGuns_Aim_bombers
Ctxt=1
MnID=0x3F18000C
Str=1069

[Cmd426]
Name=AAGuns_Aim_any
Ctxt=1
MnID=0x3F18000D
Str=1070
Key0=0x41,Cs,"shift+A";Flak-Combo

[Cmd427]
Name=AAGuns_Closing_targets
Ctxt=1
MnID=0x3F18000E
Str=1071
Key0=0x41,Cs,"shift+A";Flak-Combo

[Cmd428]
Name=AAGuns_Any_targets
Ctxt=1
MnID=0x3F18000F
Str=1072

[Cmd429]
Name=AAGuns_Update_target
Ctxt=1

[Cmd430]
Name=Man_the_deck_gun
Ctxt=1
MnID=0x3F2D0002
Str=2944

[Cmd431]
Name=AAGuns_Fire_at_will
Ctxt=1
MnID=0x3F180006
Str=1063
Key0=0x41,Cs,"shift+A";Flak-Combo

;Name=Man_the_flak_gun
;Ctxt=1
;MnID=0x3F2D0003
;Str=2945
;Key0=0x41,Cs,"shift+A";Flak-Combo

(Was in den Gänsefüßchen und hinter dem Semikolon steht ist egal)

KretschmerU99
18-05-08, 02:22
Ok, Mittelwächter - ich probiere deine Daten mal aus und natürlich habe ich auch ne sauber Inst 1.4b. Das ich da noch nicht drauf gekommen bin . . . . http://forums.ubi.com/infopop/emoticons/icon_redface.gif

Das II-A bei LSH 3.1 ist standartmäßig bereits mit Flak ausgerüstet - ich bitte dich - würde doch nie die Flak besetzen, wenn keine da ist!!! Spiele doch schon seit über 3 Jahren SH3 http://www.ubisoft.de/smileys/5.gif

Scherz bei Seite! Ich dank dir schon mal, mal sehen, wann ich testen kann . . .
Vielleicht bleibst du ja mal an der Sache mit dem WO dran http://forums.ubi.com/infopop/emoticons/icon_rolleyes.gif

Edit 1: Dein Block auf schlanker (nur LSH3.1) Version haut hin!!!!!! Also liegt der Fehler bei mir. Werde jetzt am Spiele PC mit vollem "Modeinsatz" wie ich spiele, deinen Block einfügen und testen . . . http://www.ubisoft.de/smileys/3.gif

Edit 2: Test mit meinen Sachen und meiner commandt.cfg Negativ. Habe den Block eingefügt, mit nem VII getestet, shift+A = keine Reaktion, nicht mal die Flak wird besetzt??? Aber es geht für die Standart Version von LSH 3.1 . . . Komisch, falsch machen kann ich doch gar nichts. Das muß also an meiner Command.cfg liegen. Werde die org aus LSH 3.1 nochmal mit meinen Werten abgleichen und neu testen . . . jetzt gehts aber erstmal zum Fußball . . .

EDIT 3: Habe die org command.cfg von LSH 3.1 mit meinen Ergänzungen bearbeitet und deinen Block mitreinkopiert - leider wieder nix - ich bin ratlos . . .

Fette Beute!

Rango_
22-05-08, 18:01
Mittelwaechter, danke für deine Arbeit.
Das Leben, draußen auf dem Meer ist gleich viel angenehmer mit deiner Modifikation.

Grüße Rango

KretschmerU99
24-05-08, 02:14
@mittelwaechter

Endlich, es hat geklappt! Die Flak klappt und meine weiteren Tastenbelegungen auch - habe gestern viel probiert und getestet.

Für mich steht fest, man kann nicht unbegrenzt Tataturbefehle einfügen!!! Mehrfach Positionen zuweisen scheint zu gehen siehe das mit dem batterieladen aus in Fahrstufe 3/4/5.

Aber irgendwo scheint es nur ein Kontigent für die Zuweisung allgemein zu geben. Ich habe jetzt mehrere Tasten gesperrt(die ich nicht nutze zB N;V,Y) und erneut mit
deinem Tastenblock zur Flak probiert - ging -
meine Änderungen noch dazu - ging nicht mehr!
die obrigen von mir nicht mehr genutzten Tasten deaktiviert - alles geht!

Ist schon komisch, ich denke, ich habe mind. 10 Tasten neu belegt, weiß aber nicht mehr genau, da die Großmods tw ja auch schon Tasten ändern.

Ist dir(Mittelwächter) auch schon sowas mal aufgefallen?

Jedenfalls klappts jetzt - bin voll zufrieden!
Danke für deine ausgiebige Hilfe!

http://img139.imagevenue.com/loc1187/th_13277_picture088_123_1187lo.jpg (http://img139.imagevenue.com/img.php?image=13277_picture088_123_1187lo.jpg) http://img142.imagevenue.com/loc990/th_13189_picture089_123_990lo.jpg (http://img142.imagevenue.com/img.php?image=13189_picture089_123_990lo.jpg)

Fette Beute!

Mittelwaechter
24-05-08, 03:45
Hallo KretschmerU99,

wenn mich meine Erinnerung nicht täuscht, dann ist die Zahl der Tastaturbefehle auf 190 beschränkt, bzw. es wird empfohlen, diese Zahl aus Performance-Gründen nicht zu überschreiten. Aber du willst mir doch nicht allen Ernstes sagen, dass du daran mit deiner Konfiguration schon kratzt, oder? Allerdings gibt es schon einige Tastaturbefehle alleine für die Kamerasteuerung - da ist vieles doppelt belegt.
Wenn dann deine Mods noch Tastaturbefehle mitbringen, könnte es vielleicht schon eng werden.
Solltest du wirklich mehr Befehle brauchen, dann solltest du mal bei der Kammerasteuerung nachsehen, was du nicht nützt, und entsprechend Platz schaffen. Wenn ich das so überschlage, dann solltest du dort sicherlich mindestens 40 Befehle befreien können - vorsichtig geschätzt.

Ich steuere noch einiges vom Waffenoffizier und ein zwei Sachen vom WO und vom Sonarmacker mit Tasten, und natürlich TC - aber bisher habe ich nur "V" und "B" umbelegt. Der Rest ist on Top auf die reguläre Belegung - meistens mit Shift...

Schön, dass deine Konfiguration jetzt läuft.

KretschmerU99
24-05-08, 08:45
Definitiv brauche ich noch 2 Tasten, ich schau mal nach, da gibts noch Freiraum. Bin ja selbst erst gestern drauf gestoßen. TC ist natürlich auch mit drin!!!

Danke für die Info!

MfG

Soni2
03-06-08, 02:22
Heyho,

erstmal vielen Dank für die Arbeit. Habe gestern den Shortcut für die Flak eingebaut und scheint soweit zu funktionieren.

Mal eine andere Frage ... gibt es ein Kommando, bei dem die AKTUELLE Tauchtiefe angesagt wird? Und ich meine nicht die Durchsage pro 10 Meter, sondern tatsächlich ein Tatsendruck und dann kommt sowas ähnliches wie "Aktuelle Tiefe xxx Meter."

KretschmerU99
03-06-08, 05:13
Moin Sonic,

schön wenns klappt - bei mir gehts jetzt auch:
Wenn man mehr Tasten ändert oder neu belegt muß man hier in der command.cfg

[Commands]
CommandsNb=500
MaxKeyCommandsNb=170<span class="ev_code_RED">190 zB. einfügen</span>; Keys number shoud be smaller than this value (in order to accelerate the loading)

mehr Tasten evl freischalten - ist nur eine Option, falls mal Tasten nach Änderungen in der Datei nicht mehr gehen sollten.
Für die Tiefe unter Kiel sieht es bei mir so aus

[Cmd130]
Name=Get_depth_under_sub_keel
Ctxt=1
MnID=0x3F250005
Key0=0xE2,,"&lt;"
Key1=0x44,,"D"

Weiß nicht mehr, wie das standart mäßig ist, ab so wird mir die Tiefe unter Kiel gesagt!Probiers halt mal aus!

Im übrigen lese ich deine FF Berichte sehr gern, wenn du auch mal FF Berichte anderer Kaleuns lesen möchtest . . .
Schau doch mal hier vorbei!

http://7ufl.forumieren.com/index.forum

Viel Glück und Fette Beute!
U99

Soni2
03-06-08, 05:56
Heyho,

also auf die Idee, die Taste fürs Tauchen ("D") auf die Durchsage "Tiefe unter Kiel" zu binden, wäre ich nicht gekommen. Ist aber eine geniale Idee.

Mir ging es aber um etwas anderes. Ich habe (oder hatte) den 400m Depth Gauge Mod installiert, verwende ihn aber in meinem LSH3.1 MOD Stand nicht. So habe ich den Tiefenmesser für den großen Meßbereich "nur" bis 260 Meter. Die Boote können aber tiefer. Der Typ IX etwa bis 275 Meter und einige Typ VII Varianten sogar noch weiter (ca. 300 m).

Nehmen wir mal an, ich tauche nun auf 290 Meter. Dann bekomme ich ja im Tiefenmesser nur max. 260 m angezeigt, obwohl ich tatsächlich tiefer bin. Um auf ein plötzliches Absacken oder Durchrauschen des Bootes reagieren zu können (z.B. durch Wassereinbrüche), wäre es wichtig die AKTUELLE Tauchtiefe zu wissen. Da beim Tauchen die Tiefe ja alle 10 Meter angesagt wird, müßte es theoretisch ein Kommando dazu geben, an das man ein Taste binden kann. Voilà, ich drücke $beliebige_Taste und der Obersteuermann gibt mir die aktuelle Tauchtiefe an.

KretschmerU99
03-06-08, 06:10
Hmm, da bin ich überfragt.
Ich verstehe dich, aber vielleicht hat da Mittelwaechter noch einen vorschlag.
Bei diesen Tiefen überwache ich meist selbst, da ich nur den 260m Anzeiger habe - größte Tiefe bei mir waren bisher nur bis 240m.
Die Ansage mit den 10 metern habe ich komplett deaktiviert, das nervte mich total.
Kann dazu jetzt gar nix sagen . . . Sorry!

Fette Beute!

Mittelwaechter
03-06-08, 07:04
Hallo ihr zwei,

die Tiefenansage wird vermutlich über MapZones getriggert, die damals mit einem Patch eingefügt wurden.

Theoretisch kann man in die Kampagnen zusätzliche Tiefenzonen einfügen; vielleicht auch im Abstand von einem Meter.
Ob die dann angesagt werden, steht auf einem anderen Blatt.

Bastelt eine SPM mit zwei MapZones auf 15 und auf 25 Meter Tiefe und verschmelzt sie (merge!) mit einer Kampagnen-Datei.
Dann seht, was geht!

Wird die Tiefe über 260 Meter hinaus angesagt?
Falls nicht, dann probiert auch zusätzliche Zonen in dieser Tiefe aus. Dann evtl. mit 280, 290, 300... Metern - falls die Ansage keine "fünf" unterstützt.

Sonst sollte man auch eigene Befehle entwerfen können, wird zumindest in der commands.cfg angedeutet - sicherlich in Kombination mit der 1024x768.ini. Aber da blick ich nicht ganz durch. Ich scheitere schon an einem einfachen Keybinding für die Verbrauchsanzeige.
latemail ist da der richtige Ansprechpartner!

Grüße!

Bertl01
03-06-08, 14:03
Hallo Soni2,

die Taste "a" ist zwar eigentlich dafür gedacht die momentane Tiefe zu halten.
Aber gleichzeitig wird die aktuelle Tauchtiefe auf den Meter genau angesagt.

Ist zwar blöd wenn ich eigentlich auftauchen will, und nach betätigen der Taste "a"
wieder erneut "auftauchen" befehlen muß, aber zur Not ......

Habe in der "commands.de" auch schon etliche Sachen ausprobiert,
aber leider nichts gefunden was einem nur die Tiefe über Uk-Kiel ansagt.

Grüße und gute Jagd,

Bertl

Vierkant_II
03-06-08, 23:44
Hallo Leute,

falls es jemanden interessiert:

<span class="ev_code_YELLOW">[Cmd130]
Name=Get_depth_under_sub_keel
Ctxt=1
MnID=0x3F250005
Key0=0x44,Cc,"STRG D"</span>

Damit läßt sich mit den Tasten 'Strg + D' jederzeit die Tiefe unter Kiel abrufen.

Gruß,
Vierkant II

Soni2
04-06-08, 01:29
Danke für eure Tipps. Ich habe gestern selbst eine Notlösung gefunden.

In der Dials.cfg ist für den Tiefenmesser festgelegt, welche Position (ein Winkel, in Grad gemessen - Nullpunkt ist quasi Oberkante Monitor) für Nullstellung und Maximalstellung gilt. Beim Tiefenmesser waren das jeweils 145 Grad nach links und rechts. Diese 290 Grad decken insgesamt einen Meßbereich von 260 Meter ab. Ein Meter Tiefe entspricht damit etwa 1,1 Grad Zeigerausschlag auf dem Tiefenmesser.
Ich habe den Winkel für die Maximalstellung auf 206 Grad erhöht. Das entspricht etwa einer Tiefe von 315 Metern und reicht damit für meine Zwecke gut aus. Außer dem VII C/42 sollte kein Boot in diesen Bereich vordringen können (außer dem XXI vielleicht). Wenn ich jetzt tiefer als 260 Meter tauche, wandert der Zeiger des Tiefenmessers eben in den weißen Bereich. Ich habe dann zwar keine Skala mehr, aber ich kann trotzdem in etwa abschätzen, wie tief ich bin.

KretschmerU99
04-06-08, 05:05
Coole Sache! Vielleicht könntest du ja die geänderten Blöcke aus der dials.cfg mal hier reinsetzen - wäre interessant und verhindert unnötiges experimentieren!

Wann und wo bekommst du ein VII-c/42 Boot? Dachte, das wäre deaktiviert!

Fette Beute!

Soni2
04-06-08, 05:24
Ich habe nie behauptet ein VII C/42 zu haben. Lediglich, daß normalerweise kein Boot 315 m tief tauchen können sollte, außer dem VII C/42 und evtl. dem XXI.

Der Typ IX wird bei mir in 275 Metern geknackt. Einzelne VII C Varianten kommen aber glaub ich an die 300 Meter Marke heran. Müßte mal im Detail nachsehen, was ich als Zerstöungstauchtiefe drinnen stehen habe.

Der Block für den Tiefenmesser sieht jetzt bei mir so aus:

Vorher

[Dial24]
Name=DeepDepthFdbk
Type=0; DIAL_DEPTH
Cmd=Set_depth,Crew
Dial=0x3F1F0001
CrtVal=0x3F1F0002
NewVal=0x3F1F0003
DialVal=-145,145
RealVal=0,260; meters
Circular=Yes


Nacher:

[Dial24]
Name=DeepDepthFdbk
Type=0; DIAL_DEPTH
Cmd=Set_depth,Crew
Dial=0x3F1F0001
CrtVal=0x3F1F0002
NewVal=0x3F1F0003
<span class="ev_code_YELLOW">DialVal=-145,206
RealVal=0,315; meters</span>
Circular=Yes

KretschmerU99
04-06-08, 06:39
Feine Sache, werd ich auch ändern!
Danke, Sonic!

odindnje
01-09-08, 02:10
Hallo Mittelwächter!
Dir und allen anderen Moddern auch von mir nochmals meinen besten Dank für diese tollen Tips. Sind extrem hilfreich.
Der Grund, weshalb ich mich aufraffe, mich einzuloggen, ist natürlich klar. Ich brauche Eure
Hilfe http://forums.ubi.com/infopop/emoticons/icon_biggrin.gif

Mittlerweile benutze ich das Fernglas sehr gerne und würde es gerne mithilfe des "Toggle"-Befehls mit der B-Taste auf- und absetzen, also die Sicht aktivieren und wieder zur vorherigen Sicht zurückkehren (also zur Brücke). Meine Experimente in der Commands_de.cfg waren leider nicht von Erfolg gekrönt. Habt Ihr (also vielleicht Du, Mittelwächter, gerne aber auch jemand anders http://forums.ubi.com/infopop/emoticons/icon_wink.gif einen Tip?

Ich hätte vielleicht sogar ganz gerne ein Fadenkreuz mit Skala, gibts ja in echt auch. Das ist nicht zufällig sonst irgendwo implementiert?

Für Eure Hilfe bereits vorab besten Dank von einem seit drei Jahren begeisterten SHIII-Spieler.

Mittelwaechter
01-09-08, 07:49
Hallo odindnje,

Welche Mods spielst du denn?

Mit GWX2.0 sieht das so aus:

[Cmd18]
Name=Binocular_camera
Ctxt=1
Key0=0x42,,"B"
Page=0x27000000,3706
GoBack=Conning_deck_camera

Sollte funktionieren, solange du "B" nicht noch anderweitig belegt hast. Ob die Page in einem anderen Mod identisch ist, weiß ich nicht.

Zum Fadenkreuz kann ich dir leider nicht wirklich helfen.

Grüße!

odindnje
01-09-08, 18:28
Hallo Mittelwächter,
besten Dank für die fixe Antwort. Bei mir steht da noch eine "MnID=0x3F460002"-Zeile zusätzlich, weiß aber nicht, ob das bei der Werks-Ausgabe schon drin war. Habe grade mal nachgezählt: In meinem JSGME stehen derzeit rund 190 Mods, davon etwa 80 aktiviert http://forums.ubi.com/infopop/emoticons/icon_smile.gif Sind vorwiegend kleine Sachen, da ich meinem alten 2001-er Athlon nicht zu viel zumuten wollte...

Was ich meinte, war, durch nochmaliges Drücken der B-Taste wieder zur Brücke zurück zu gelangen. Das steht bspw. beim KTB ("K")als "Togggle"-("umschalt")-Befehl drinne. Oder beim Funklogbuch "M". Gleichgültig, auf welcher Station man sich befindet, kann man mit diesen Befehlen das KTB oder das Funklog aufrufen und durch nochmaliges Drücken wieder zur vorherigen Station zurückkehren. Ist halt einfacher, geht aber natürlich auch mit der Ziffernblock-Einfügetaste.

Nun gut, will nicht quengeln, habs ja drei Jahre als Passiv-Forumsteilnehmer geschafft http://forums.ubi.com/infopop/emoticons/icon_cool.gif wer weiß, vielleicht findet sich ja irgendwann noch ein passender Hinweis. Dir und natürlich allen anderen Langzeit-gamern weiterhin viel Spaß mit dieser geilen Sim. http://www.ubisoft.de/smileys/zombi.gif

Mittelwaechter
02-09-08, 05:07
Hallo odindnje,

darf ich fragen, warum du nicht einfach das Mausrad verwendest? Hast du das anderweitig belegt?

Grüße!

odindnje
06-09-08, 06:48
Hallo Mittelwächter,
danke für den Tip. Den kannte ich zwar schon mal, muß ihn aber wohl verdrängt haben. http://forums.ubi.com/images/smilies/35.gif Sache hat sich damit erledigt. Frohes Treiben weiterhin http://www.ubisoft.de/smileys/chatten.gif