PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Massive FPS Probleme im Spiel (Beta war nicht betroffen).



ThePidoc
16-04-19, 08:29
Die Beta lief bei mir perfekt. Immer über 100 FPS. Das releaste Game hat nun konstant um die 20fps bei mir und laggt, obwohl ich definitiv die selben Grafikeinstellungen habe.
Ich habe die Steam Version und bin leider nicht der einzige der dieses Problem hat. Es gibt dazu schon die ersten Threads in der Steam Community

:(

kL1ck85
16-04-19, 08:37
geht mir genauso , closed und open beta liefen echt stabil
jetz hab ich dauerhafte 5 fps
habs auch auf Steam

closed und open beta sind gelöscht sowohl auch deren dokumente
steam overlay deaktiviert
bringt alles nix

AMD Treiber 19.4.1

ThePidoc
16-04-19, 08:41
Ich habe eine Nvidia GTX 970. Betrifft also wohl beide Hersteller. Oder generell ein Steam Problem?

kL1ck85
16-04-19, 08:42
gute frage da ich hier im forum nix weiter gefunden habe, betrifft es wohl eher steamuser

ThePidoc
16-04-19, 08:46
Ich hatte mich so gefreut heute endlich richtig spielen zu können und dann das. Jetzt wird man als Steam Vorbesteller doch noch bestraft :((((

MattMcCorman
16-04-19, 09:12
Falls ihr mit einem Rechner spielt, der zwei Grafikkarten hat: Schaut in den Grafikkarteneinstellungen nach, welche er für das Spiel nimmt, notfalls weist die stärkere GPU direkt zu. Die Grafikkarten-Auswahl in ANNO 1800 selbst funktioniert wohl nicht immer.

Wenn das nicht der Fall ist: Löscht mal den Inhalt des Shader-Cache unter Dokumente/Anno 1800. Falls dort noch die vorkompilierten Shader der Beta drin sind, kann es ggf. zu Problemen kommen.

ThePidoc
16-04-19, 09:19
Das habe ich auch schon ausprobiert und hat leider auch nicht geholfen. Ich habe die Grafikkarte auch für Steam manuell gesetzt etc.

kL1ck85
16-04-19, 09:24
ich bin nur auf einer GPU unterwegs
MSI R7 370 4g

hab eben mal den neuen treiber 19.4.2 geladen mal sehen ob es was bringt

dokumente hatte ich schon gelöscht wie geschrieben


ok 19.4.2 funktioniert auch nicht

FamoussV
16-04-19, 12:32
push!

Ubi-kAn
16-04-19, 12:45
Hallo Annojaner!
Das ist natürlich ärgerlich. Habt ihr dieses Problem generell, oder tauchen die FPS drops an bestimmten Orten oder Handlungen auf? Könnt auch gerne ein Video-Link hochladen, sodass wir uns das mal genauer ansehen können.

Snurgy
16-04-19, 12:49
Hallo Annojaner!
Das ist natürlich ärgerlich. Habt ihr dieses Problem generell, oder tauchen die FPS drops an bestimmten Orten oder Handlungen auf? Könnt auch gerne ein Video-Link hochladen, sodass wir uns das mal genauer ansehen können.

also ich habe einfach direkt im menü probleme, direkt 10 fps maximal mal 15, es springt auch mal auf 80, aber nur für millisekunden, ebenso habe ich wenn ich anno starte extreme ping problem , im ts steigt der ping auf 300+

Dr3verebensee
16-04-19, 13:43
Bei mir gehen die Fps so in den Keller das das Spiel immer abstürzt! Bei der Kampagne komm ich erst gar nicht rein und im freien Spiel bekomm ich nur kurz die Karte zu sehen!

I7 7700
Gtx 1060
16 gb ram

CX_Felishya
16-04-19, 15:24
Ich schließe mich in diesem Thread auch noch mal an.

Konstantes Stuttering.
Aktuelle Treiber.

Steam Overlay deaktiviert, Steam auf Offline: Keine Änderung.

kL1ck85
16-04-19, 16:16
die offizielen antworten hier sowie im englischen forum fühlen sich so an als würde man mit BOTS schreiben

da fühlt man sich direkt noch verarschter als ohnehin schon mit steam !!

was wollen die denn mit nem video ? allein dafür brauch ich viel zu viel zeit mit meiner leitung was hochzuladen

ich hab nen spiel für 70€ gekauft ich lass mich hier nicht zum Testaffen machen das ist kein Eary Access verdammt

Ubi-Com_Raven
16-04-19, 16:19
Ich würde euch bitten mal zu versuchen sowohl im Steam als auch im Uplay offline zu gehen und zu schauen ob es zu höheren FPS führt.

kL1ck85
16-04-19, 16:46
das 192mb update hats nicht gebracht :mad:

aber ja STEAM OFFLINE schalten bringt es tatsächlich :confused:
zumindest bei mir ich hab durchgehend 60FPS (vsync)

UPLAY is nicht auf offline , wenn ich das machen müsste wäre anno für mich gestorben, da ich zur Multiplaygemeinde gehöre.

Snurgy
16-04-19, 17:02
bin nur in steam offline, kann jetzt spielen 144 fps, nicht schwankend!

theheroroland2
16-04-19, 17:08
https://www.youtube.com/watch?v=Bq5KdMAPcBY&feature=youtu.be

iZnoGouDx
16-04-19, 17:19
@Ubi-kAn nein das Stuttern ist die ganze Zeit. Auch ich hatte keinerlei Probleme in der Alpha, Closed/Open Beta... doch die Release Fassung ist unspielbar!

iZnoGouDx
16-04-19, 17:22
wie bereits unzählige Leute berichtet haben: stellt man steam/uplay auf offline mode verschwinden die Probleme.. nur kann man so nat nicht auf dauer spielen UND SCHON GARNICHT MULTIPLAYER!. Liegt wohl an dem berhassten Kopierschutz denuvo, der bei Anno zum Einsatz kommt: einzig logische Schlussfolgerung.

Dr3verebensee
16-04-19, 17:31
Ich komm gar nicht soweit, und bei mir lässt sich auch nicht auf dx 12 umstellen bzw. umstellen schon aber es speichert das nicht nachdem ich neu gestartet hab!

LadyHahaa
16-04-19, 17:32
kleiner Hinweis am Rande
man kann seine Beiträge bearbeiten, und weiteren Text hinzufügen

https://cdn.discordapp.com/attachments/533825975964794900/567733765275779073/bearbeiten.jpg

Dr3verebensee
16-04-19, 17:52
Ich komm gar nicht soweit, und bei mir lässt sich auch nicht auf dx 12 umstellen bzw. umstellen schon aber es speichert das nicht nachdem ich neu gestartet hab!

Ok, danke! Hilft mir hier aber auch nicht weiter!

Es will bei mir ja nichtmal die Einstellungen speichern wenn ich auf dx 12 umstelle oder die Grafikqualität ändere!

ThePidoc
16-04-19, 17:56
im englischen Board hier wurde es nun an die DEV's weitergegeben.

Ubi-Com_Raven
16-04-19, 18:01
Könntet ihr testen ob sich die Performance während ihr im Steam online seid verbessert habt? Und zur Klarstellung: Nein, die Probleme haben nichts mit Kopierschutz zu tun.

CX_Felishya
16-04-19, 18:30
Leider bleibt bei mir das Stuttering, egal ob Steam oder Uplay oder beides auf offline gestellt ist.

Dr3verebensee
16-04-19, 18:41
Leider bleibt bei mir das Stuttering, egal ob Steam oder Uplay oder beides auf offline gestellt ist.

Hab jetzt unter den Kompatibilitätsmodus mit rechtsklick auf „Anno 1800“, zumindest mal den freien Spiel Modus zum Laufen gebracht!
Ohne stottern sogar!
Aber die Kampagne bekomm ich immer noch nicht zum laufen!

Deramond.
16-04-19, 18:55
Habt ihr mal versucht euere Grafikkarten Treiber komplett neu zu installieren? Das hilft oft bei solchen Problemen.
Kann hier DDU sehr empfehlen, hat mir schon oft geholfen.

https://www.guru3d.com/files-details/display-driver-uninstaller-download.html

CX_Felishya
16-04-19, 18:57
Das habe ich am Anfang bereits versucht. Erwartungsgemäß hat das aber nichts gebracht.

Wie gesagt, sei betont, dass die Closed und Open Beta keine Probleme mit dem Stuttering hatten.
Zudem betrifft es scheinbar nur die Steam-Version. Hardware- und Treiberprobleme können also ausgeschlossen werden.

An sich werden mir auch 60 FPS angezeigt. Allerdings läuft es mit einem enormen Stuttering (also KEIN FPS-Drop).

CX_Felishya
16-04-19, 18:58
Hab jetzt unter den Kompatibilitätsmodus mit rechtsklick auf „Anno 1800“, zumindest mal den freien Spiel Modus zum Laufen gebracht!
Ohne stottern sogar!
Aber die Kampagne bekomm ich immer noch nicht zum laufen!

Was hast du eingestellt?

Dr3verebensee
16-04-19, 19:18
Was hast du eingestellt?

Rechtsklick auf deine Anno Verknüpfung am Desktop, danach behandeln von Kompatibilitätsproblemen danach windows 7 Version und als Administrator ausführen!

So richtig funktionierts aber noch immer nicht! Bei der Kampagne hab ich immer noch Probleme diese zum laufen zu bringen!

ThePidoc
16-04-19, 19:23
Also Steam Offline zu setzen und dann mit Uplay Online zu spielen hat bei mir auch geholfen. Das Spiel läuft jetzt flüssig mit ca. 60 fps (VSYNC OFF). In der Beta hatte ich mit den gleichen Settings aber über 100 FPS (VSYNC OFF).

PainComplex
16-04-19, 20:19
Bitte arbeitet schnell an einer Lösung !
Das Spiel im Offline Modus zu Spielen ist keine dauerhafte Lösung !

Aldarean_
16-04-19, 20:43
Hallo,

ich spiele mit einem AMD Ryzen 2700X und einer RTX 2080 auf Full HD und habe auch Mühe, die 60 FPS zu halten. Besonders über großen Städten sacken die FPS extrem ab. Das Schalten in den Offline Modus hat es etwas gebessert.

FaiNx3
16-04-19, 21:33
Gleiches Problem hab ich auch trotz 100+ FPS stottert es dennoch. Der Kompatibilitätsmodus hat schon etwas gebracht aber die Bewegung der Kamera ist immer noch ruckelig.


Specs:
MSI GTX 1080ti 11G
I7-4790k @ 4.5 ghz
16gb ram @ 1600 mhz

Shadow091995
16-04-19, 21:56
Selbes Problem. Steam version. Beta lief hervorragend.
Laut FPS Anzeige 90FPS aber es stuttert bis zu geht nicht mehr.
(Youtube-Video: https://www.youtube.com/watch?v=hdBxmawA-VE )

Steam & UPlay offline bringt nichts. Steam Offline, Uplay Online auch nicht. Kompatibilitätsmodus ebenfalls nicht.
Keine Besserung von DX11 auf 12 und umgedreht.

Ich habe einen Ryzen 7 1800X übertaktet auf 3,9GHz, eine GTX 1070Ti ebenfalls übertaktet, 32GB RAM 2666MHz. Treiber alle aktuell.

Erst wird das Spiel bei Steam 18 Stunden später released und dann noch sowas :mad:
Bitte fixen, ich freu mich so sehr das Spiel zu suchten :D

PainComplex
16-04-19, 22:12
Selbes Problem. Steam version. Beta lief hervorragend.
Laut FPS Anzeige 90FPS aber es stuttert bis zu geht nicht mehr.
(Youtube-Video: https://www.youtube.com/watch?v=hdBxmawA-VE )

Steam & UPlay offline bringt nichts. Steam Offline, Uplay Online auch nicht. Kompatibilitätsmodus ebenfalls nicht.
Keine Besserung von DX11 auf 12 und umgedreht.

Ich habe einen Ryzen 7 1800X übertaktet auf 3,9GHz, eine GTX 1070Ti ebenfalls übertaktet, 32GB RAM 2666MHz. Treiber alle aktuell.

Erst wird das Spiel bei Steam 18 Stunden später released und dann noch sowas :mad:
Bitte fixen, ich freu mich so sehr das Spiel zu suchten :D


Sieht bei mir genauso aus ...

https://www.youtube.com/watch?v=uxDeVAIZFog

(Gtx 1080ti, i9 9900k 128gb ram 2 tb ssd)

Shadow091995
16-04-19, 22:20
Sieht bei mir genauso aus ...

https://www.youtube.com/watch?v=uxDeVAIZFog

(Gtx 1080ti, i9 9900k 128gb ram 2 tb ssd)

Und du hast sogar ein wesentlich stärkeres System.
Ich hatte schon Angst, dass es an meinem PC liegt und der Denuvo Kopierschutz nun nach der Beta richtig implementiert ist und richtig reinhaut.

Dann können wir wirklich nur auf einen schnellen Fix hoffen!

FaiNx3
16-04-19, 23:06
Sieht bei mir genauso aus ...

https://www.youtube.com/watch?v=uxDeVAIZFog

(Gtx 1080ti, i9 9900k 128gb ram 2 tb ssd)

Genauso sieht das bei mir auch aus.

Helfen5661
16-04-19, 23:14
Hab das selbe Problem...

PainComplex
17-04-19, 00:01
[QUOTE=Shadow091995;2602532]Und du hast sogar ein wesentlich stärkeres System.
Ich hatte schon Angst, dass es an meinem PC liegt und der Denuvo Kopierschutz nun nach der Beta richtig implementiert ist und richtig reinhaut.

Dann können wir wirklich nur auf einen schnellen Fix hoffen



Denke auch das es am Kopierschutz liegt.
Bei mir hört das Problem auch sofort auf wenn ich den Lan Stecker ziehe bzw. Offline in Steam und Uplay gehe ...

Shadow091995
17-04-19, 00:55
Denke auch das es am Kopierschutz liegt.
Bei mir hört das Problem auch sofort auf wenn ich den Lan Stecker ziehe bzw. Offline in Steam und Uplay gehe ...

Eben Probiert, hat bei mir gar keinen Unterschied gemacht. Also in Windows den Ethernet-Adapter zu deaktivieren. Sollte ja das selbe sein wie LAN-Kabel ziehen.

Raewyr
17-04-19, 03:10
Ich trag auch mal meinen teil bei,

Steam online + Uplay online = 5fps,
Steam offline modus + Uplay online = alles super

i7 6700k
GTX 1070ti
Win 10

Steam im offlinemodus zu haben ist für mich leider keine dauerhafte Lösung und ich hoffe das da bald ein Fix dafür kommt

Shadow091995
17-04-19, 04:23
Also irgendwas hat jetzt hier zumindest teilweise funktioniert und der Steam Offline Modus funktioniert nun auch bei mir und das Spiel läuft super flüssig wie in der Beta. Da ich Steam momentan sowieso nicht nutze und man ja via UPlay im Multiplayer spielt, ist das erstmal für mich Spielbar :D

Aber bitte, liebes Dev-Team, trotzdem einen Fix erstellen <3

Helfen5661
17-04-19, 05:51
Steam offline +Uplay online - - > keine Probleme

Ärgert mich das grad, dass ich es auf steam gekauft hab.. :l

MiPulino
17-04-19, 09:49
@Ubisoft
Werden hier noch weitere Videoaufnahmen benötigt?

Habe bei mir leider das selbe Problem, Offline gehen bei Steam/Uplay ergab leider keinen Erfolg.

Ubi-Com_Raven
17-04-19, 09:49
Wir arbeiten an einem Fix für das Problem für unseren nächsten Patch. Und wie schon zuvor gesagt hat das Problem nichts mit dem Kopierschutz zu tun, sondern es ist ein Fehler dabei wie das Spiel mit der Steam Friends List interagiert, das vor allem Spieler mit einer größeren Anzahl an Freunden betrifft.

Aldarean_
17-04-19, 10:36
@BB_Com_Raven : Bei mir tritt das Problem auch auf und ich habe eine reinen Uplay Key.

Ubi-Com_Raven
17-04-19, 11:08
@BB_Com_Raven : Bei mir tritt das Problem auch auf und ich habe eine reinen Uplay Key.

In dem Fall wäre es dann eine andere Ursache als bei einigen der Steam User.

Raewyr
17-04-19, 16:36
Wir arbeiten an einem Fix für das Problem für unseren nächsten Patch. Und wie schon zuvor gesagt hat das Problem nichts mit dem Kopierschutz zu tun, sondern es ist ein Fehler dabei wie das Spiel mit der Steam Friends List interagiert, das vor allem Spieler mit einer größeren Anzahl an Freunden betrifft.

Danke für die Info das Ihr wisst woran es liegt und daran arbeitet. Irgendeine Idee wielange es dauern wird bis das was kommt? (Vor dem Osterwochenende oder eher dannach?)

ThePidoc
19-04-19, 12:32
Wer einen reinen Uplay Key hat. Schonmal probiert Steam zu schließen? Vielleicht liegt es generell daran, dass Steam auf dem Rechner läuft.

Shadow091995
19-04-19, 20:45
Wer einen reinen Uplay Key hat. Schonmal probiert Steam zu schließen? Vielleicht liegt es generell daran, dass Steam auf dem Rechner läuft.

Sobald man Steam zu hat und bei Uplay auf Spielen geht, startet sich Steam. Genauso wie wenn man in Steam auf Spielen geht, startet sich UPlay. Das war damals bei den älteren Assassins Creed Teilen besser gelöst. Da hat sich der Key in Uplay verknüpft und man konnte es auch nur in Uplay starten, statt immer alles über Steam laufen zu lassen.

ThePidoc
20-04-19, 11:44
Ja deswegen habe ich geschrieben wer einen "reinen" Uplay Key hat. Ohne Steam. Weil es schreiben hier auch welche, dass sie die FPS Probleme ohne Steam haben.

Shadow091995
20-04-19, 14:36
Ja deswegen habe ich geschrieben wer einen "reinen" Uplay Key hat. Ohne Steam. Weil es schreiben hier auch welche, dass sie die FPS Probleme ohne Steam haben.

Da nur die Steam Version diese Probleme hat, weil etwas mit der Freundesliste nicht passt, sollte das dann widerum ein anderes Problem sein.

TKRadiant
20-04-19, 16:59
Selbes Problem bei mir.


Steam Offline-Modus hilft zwar, aber für mich eine inakzeptable Lösung. Weder Spielzeit, noch Achievements werden bei Steam gespeichert (dank Offline modus)...

CX_Felishya
22-04-19, 23:35
Da das Problem noch immer nicht behoben wurde, werde ich nun einen Refund beantragen.

Schilli92
23-04-19, 14:21
Moin Moin zusammen,

ich gebe meinen Senf nun auch einmal dazu:

Intel iCore I7 7700K
GTX 1070 GTX
16 GB Arbeitsspeicher
Anno 1800 Uplay Key

Habe nun etwas über 10K Einwohner und meine FPS dropt auf 20-30 FPS herunter. Ich habe bereits auf DirectX12 umgestellt, konnte dadurch allerdings nur ca. 5 FPS mehr heraus holen. Ich werde heute Abend mal versuchen Steam zu beenden und sehen ob sich dann was ändert...

Stoni1069
23-04-19, 15:08
Tach werte Annogemeinde oder Leidgeplagte.

Mit der Ziffer 25 wird an diesem Tage ein Patch avisiert,
der dem einhalt gebieten soll. Vor allem soll das die Steam-User
betreffen.

Zum Zweiten hat AMD seinen Treiber mit der Version 19.4.2 für
Anno 1800 Optimiert. Jetzt gibt es bereits 19.4.3. AMD zieht da
recht fix mit. Wie es sich bei NVidia-GraKaTreiber verhält, kann ich
aus dem Stegreif nicht sagen.

Angemerkt sei nun, dass ich auch etwas mehr als 10k Einwohner
hab und nichts passiert. Weder Laggs noch Stuttering oder gar FPS-downs.
Alles Schick. Mal sehen wenn man mehr als 20k hat, 10 Schiffe usw...

Gruß
Stoni

MaggoMeggl
23-04-19, 15:21
Moin Moin zusammen,

ich gebe meinen Senf nun auch einmal dazu:

Intel iCore I7 7700K
GTX 1070 GTX
16 GB Arbeitsspeicher
Anno 1800 Uplay Key

Habe nun etwas über 10K Einwohner und meine FPS dropt auf 20-30 FPS herunter. Ich habe bereits auf DirectX12 umgestellt, konnte dadurch allerdings nur ca. 5 FPS mehr heraus holen. Ich werde heute Abend mal versuchen Steam zu beenden und sehen ob sich dann was ändert...

Es liegt definitiv an Steam.
Ich spiele mit einem 6700K, 16GB RAM und einer 970 GTX und habe diese Probleme nicht. (über 20.000 Einwohner)
Warte auf das heutige Update und halte nach einem neuen NVIDIA Treiber ausschau :-)

Raewyr
23-04-19, 18:26
Ich denke mal das es mit dem m nächsten Patch behoben wird der am 25.4 also Donnerstag kommt. Jedenfalls steht das was zur steamversion und low fps in den patchnotes ( https://www.anno-union.com/wieviel_ostereier_sind_im_spiel/)