PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Screen-Tearing und Mikro-Ruckler (trotz guter Hardware)



BreachingEnte
11-04-16, 19:01
Hey zusammen,

ich bin seit geraumer Zeit etwas in R6 Siege zugange. Nach einiger Spielzeit ist mir nun allerdings aufgefallen, dass die Grafikoptionen noch nicht ganz optimal zu sein scheinen.
Hier erstmal alle Settings vorweg:



1920x1080
VSync: off
Texture Quality: Very High
Texure Filtering: 16X
LOD Quality: Very High
Shading Quality: High
Shadow Quality: High
Reflection Quality: High
Ambient Occlusion: HBAO
Lens Effects: off
DoF: off
AA: MSAA 4x



Hardware:



i5 6600K @ 3,5 GHz (Prolimatech Genesis)
ASUS R9 290X Matrix (Raijintek Morpheus)
MSI Z170M Mortar
2x8 GB HyperX Fury CL15 2400 MHz
Samsung EVO 850 500GB
be quiet E10 500W
Samsung SyncMaster BX2450


Und nun zum eigentlichen Problem:

Trotz stabiler Framerate von meist 50 FPS habe ich ständige Mikroruckler. Das ganze ist auch davon abhängig, welchen Fenstermodus ich im Spiel ausgewählt habe:
wenn ich auf "Fullscreen" ohne VSync spiele, habe ich beim schnellen Bewegen durch die Map das Gefühl, als würden die Wände schmelzen :rolleyes:
In diesem Zustand sind die Zeilenverschiebungen kaum zu ertragen, dafür läuft das Spiel aber grundlegend sehr flüssig bzw. ohne Ruckler/Aussetzer. Wenn ich VSync hinzuschalte, sinkt die Framerate um locker 15 FPS und ich habe durchgehende Ruckler. Der Bildaufbau ist dann zwar nicht mehr verschoben, dafür fühlt es sich aber an, als hätte ich nur noch 25 FPS.
Im "Borderless" Modus ohne VSync läuft es prinzipiell noch am flüssigsten, weitestgehend auch ohne verschobene Zeilen. Allerdings habe ich auch da relativ oft kurze Aussetzer, insbesondere bei Bewegungen. Nehme ich dann wieder Vsync hinzu, bricht wieder die Framerate ein und Bewegungn fühlen sich extrem abgehackt an...

Nun habe ich schon mit ein paar Einstellungen rumgespielt:
- Konstanten Takt erzwungen (always 3D Clock in GPU Tweak II)
- Treiber-Update (Crimson von 16.3.1 auf 16.3.2)
- Framelock auf 60 FPS
- Wechseln zwischen 59 Hz und 60 Hz (im "Fullscreen" Modus)
- Absenken der Grafikeinstellungen (auch bei 100-200 FPS bleiben die Probleme bestehen)

So ganz hat bisher aber noch nichts geholfen.
Im "Borderless" Modus läuft es noch "annehmbar" flüssig. Aber gerade bei schnellen Bewegungen treten dann doch immer wieder kurze Ruckler auf. Es fühlt sich beim Umsehen und Bewegen trotz der 50+ Frames immernoch etwas "indirekt" und "schwammig" an.

Die 290X und der 6600K laufen vom Takt her konstant bzw. ohne größere Einbrüche, Temps sind im absolut grünen Bereich.

Woran könnte es noch liegen?
Gibt es speziell für dieses Spiel irgenwelche Workarounds oder Config-Tweaks, die man noch ausprobieren könnte?
Bin mit meinem Latein so langsam am Ende :(

Würde mich über ein paar Tipps sehr freuen...

Gruß,
Pekigente

TheRealSam
12-04-16, 05:45
Hi,

ich kann dir ja mal meine Einstellungen sagen, aber wir haben komplett unterschiedliche Systeme.
Daher heißt das nicht, dass es bei dir mit den gleichen Einstellungen besser ist.
Es könnte auch einfach eine Hardwareunverträglickeit sein.

Texture Quality: High
Texture Filtering: Anisotropic 4x
LOD Quality: High
Shading Quality: Medium
Shadow Quality: High
Reflection Quality: Medium
Ambient Occlusion: SSBC
Lens Effects: Off
Zoom-In Depth of Field: On
Post-Process Anti Aliasing: T-AA
Multisample Anti-Aliasing: Temporal Filtering

Resolution: 1920x1080
VSync: Off

Ich habe mit diesen Einstellungen keine Probleme
System:

I7-4700MQ
Nvidia GTX770M (Laptop also)
16GB RAM
Spiel läuft auf einer 1TB HDD (7200RPM)

Konkrete Tipps kann ich sonst leider nicht geben.
Hoffe, es hilft trotzdem ein wenig.

BreachingEnte
13-04-16, 15:41
Hey Sam,

danke für deine Antwort!

Habe aber nun nochmal ein paar Durchläufe bei rund 150 FPS gemacht, sprich die Settings einfach auf Niedrig gestellt. Erstaunlicherweise treten in diesem Fall doch deutlich weniger Mikroruckler auf - auch die Zeibenverschiebungen im Fullscreen sind deutlich geringer. Ich gehe davon aus, dass das Problem an einer unzureichenden Synchronisation zwischen Bildschirm und Grafikkarte liegt. Da ich aber "nur" einen 60 Hz Monitor und auch noch kein FreeSync habe, werden unterhalb der 60 FPS denke ich mal einige Bilder doppelt ausgegeben beziehungsweise übrsprungen.
Habe auch mal eine andere Grafikakrte eingebaut, das Problem besteht aber weiterhin. Daher wird es mit hoher Wahrscheinlichkeit mit meinem alten SyncMaster zusammenhängen. Da die Performance mit VSync bisher noch ziemlich bescheiden ist, muss wohl einfach ein neuer Monitor mit bestenfalls 144 Hz und FreeSync her :(
Bis dahin werde ich wohl mit dem Kompromiss leben müssen, die Einstellungen in so weit zu senken, dass ich stabile 60 Frames bekomme.

Danke dennoch für die Hilfestellung!

Gruß,
Pekingente

Nachtrag:

Bin nun sogar schon so weit gegangen, meinen jetzigen LCD etwas zu übertakten. Per Custom Resolution Utility läuft er auch problemlos mit 70-75Hz. Im Spiel macht sich das sogar bemerkbar - nur lassen sich die Probleme mit der schlechten Synchronisation zwischen Grafikkarte und Bildschirm damit auch nicht vollends umgehen.

Die bisherigen Tendenzen bei den Einstellungen bleiben bestehen:

Fullscreen ohne VSync: flüssig, aber Tearing
Fullscreen mit VSync: ruckelig, kein Tearing
Borderless ohne VSync: Mittelweg zwischen beidem
Borderless mit VSync: ruckelig, kein Tearing

Ich kann mir also aussuchen, ob ich entweder Mikroruckler oder Zeilenverschiebungen haben will, oder ein wenig von beidem :D

Mal sehen. Vielleicht kommt in diesem Jahr ja noch ein brauchbarer IPS-Monitor mit 144 Hz und FreeSync raus. Dann dürfte sich das Thema eigentlich erledigt haben, sofern es nicht doch noch ein treiberseitiges Problem mit den aktuellen Crimsons von AMD ist.

TheRealSam
15-04-16, 15:26
Danke für das Update.
Nur blöd, dass es sich anscheinend bei deinem aktuellen Setting nicht lösen lässt. :(