PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Grafikfehler Cat 4 oder FB AEP?



frizz
26-03-04, 06:49
Bei der Einstellung "perfect" zeigen sich sehr unschöne sternfömige Strukturen vor allem in bewaldetem Gebiet. Dies viel mir erst nach der Installation von AEP auf. Versuche mit dem alten Catalyst 3.7 waren erfolgreich, liefen sogar ein bisschen schneller, jedoch hängt sich der ganze PC auf sobald ich beim Fliegen die Karte einblende. Danach wieder CAt 4.1 und auch Cat 4.7 installiert. PC hängt sich nicht mehr auf, aber jetzt sind diese fürchterlichen "moire" Effekte wieder da. Wie gesagt, nur "perfect". Da ich fast ausschließlich Pazifik fliege hätte ich schon gern das "Wasser mit Höhengefühl"
Jemand ähnliche Erfahrung gemacht, oder weiß jemand abhilfe?

frizz
26-03-04, 06:49
Bei der Einstellung "perfect" zeigen sich sehr unschöne sternfömige Strukturen vor allem in bewaldetem Gebiet. Dies viel mir erst nach der Installation von AEP auf. Versuche mit dem alten Catalyst 3.7 waren erfolgreich, liefen sogar ein bisschen schneller, jedoch hängt sich der ganze PC auf sobald ich beim Fliegen die Karte einblende. Danach wieder CAt 4.1 und auch Cat 4.7 installiert. PC hängt sich nicht mehr auf, aber jetzt sind diese fürchterlichen "moire" Effekte wieder da. Wie gesagt, nur "perfect". Da ich fast ausschließlich Pazifik fliege hätte ich schon gern das "Wasser mit Höhengefühl"
Jemand ähnliche Erfahrung gemacht, oder weiß jemand abhilfe?

MHD84
26-03-04, 07:30
Ich kann es nur bestätigen, die Grafikfehler unter perfect...auch das Terrain wird manchmal falsch dargestellt. Woran es liegt, hab ich keine Ahnung.
Wenn du sagst, mit dem Cat 3.7 war es nicht, kann es ja an der aktuellen Cat. Version liegen. Ich habe aber keine Ahnung, ob das stimmt

--- Born to raise hell ---

InsaneDruid
26-03-04, 08:27
Kannst du mal bitte n Screenie machen?

Ich hatte letztens auch Probs, ist mir schonmal aufgefallen (vor ACE in ner selbstgebastelten Mission), war letztens auf der Finnland Map, gleich die erste Russen-Einzelmission ("Tiefangriff").. auf den Wäldern zeigten sich unschöne Flächen, in denen die Textur total unscharf war. "sternfömig.. naja könnte man so nennen.

Ich hab jetzt 45 Minuten versucht diesen Effekt wiederherzustellen, ohne "Erfolg".. will sagen momentan läufts hier bestens. Nutze den 4.3er Catalyst mit der 4.2er Atioglxx.dll.

Hab mit und ohne FSAA/AF getestet, mit Forest 0 und 3.. den 4.3er "pur" (ohne die dll).. auch damit liefs fehlerfrei (nur langsamer als mit der dll)..

---
http://www.heidegrundschule.de/darksun/skinslogo.jpg (http://www.il2skins.com/?action=list&whereauthorid=InsaneDruid&comefrom=display&ts=1049772896)

Willey
26-03-04, 12:52
Hmm hab auch n Grafikfehler bei Perfect, aber auch mit den 3.7ern. Mit allen Treibern.

Mal n paar Threads dazu:
http://ubbxforums.ubi.com/6/ubb.x?a=tpc&s=400102&f=49310655&m=996106092
http://ubbxforums.ubi.com/6/ubb.x?a=tpc&s=400102&f=49310655&m=193107092
http://ubbxforums.ubi.com/6/ubb.x?a=tpc&s=400102&f=23110283&m=396100162&r=396100162#396100162

Es liegt laut Yuri Kryachko (n Grafiker bei Maddox) an dem Line Antialiasing, was bei der Karte und den Tracern benutzt wird. ("It's conflict between line antialiasing and shaders (confirmed by ATI developer relations).")

Wie ich es reproduzier:
Karte öffnen, mehr nicht.
Wenn ich die dann wieder wegmach, bleibt der Fehler entweder oder er geht wieder weg und es ist wieder normal.
Wenn der nicht weggeht, n paar Kugeln (so daß sichtbare Tracer fliegen), und schwupps isses wieder normal.

Daher kann man es auch nicht in Tracks fassen, denn ohne die Karte gibts den Fehler nicht.

http://home.arcor.de/eldur/sig/willey110.jpg
http://home.arcor.de/eldur/smilies/16x16_smiley-surprised.gif http://home.arcor.de/eldur/smilies/16x16_smiley-surprised.gif http://home.arcor.de/eldur/smilies/16x16_smiley-surprised.gif

InsaneDruid
26-03-04, 13:06
Ja genau das meine ich. Hatte ich 2-3mal bislang, wie gesagt habs heute den ganzen Tag (naja ne Stunde insgesamt, dann hab ich weiter Silent Storm gezockt http://ubbxforums.ubi.com/infopop/emoticons/icon_smile.gif ) versucht zu reproduzieren-ohne Erfolg.

Schonmal den Cata 4.3 mit 4.2er dll getestet? Auf welche Map ist es bei dir am stärksten?

Btw.. Line Antialiasing.. ich glaube da verwuchselt der gute Mann was, Line AA wird idR nur von den Profi Karten (FireGL) supportet. Na ich denke er meint FSAA im allgemeinen.

---
http://www.heidegrundschule.de/darksun/skinslogo.jpg (http://www.il2skins.com/?action=list&whereauthorid=InsaneDruid&comefrom=display&ts=1049772896)

InsaneDruid
26-03-04, 13:12
Nochmal ich.. nachdem ich deine Treads da gelesen habe.. jaaa Map hatte ich natürlich heute nicht auf.. ohne FSAA und AF war MAP genau der "Trigger" für dieses Problem. Mit 4xFSAA und 2xBi-AF wars aber nicht.

---
http://www.heidegrundschule.de/darksun/skinslogo.jpg (http://www.il2skins.com/?action=list&whereauthorid=InsaneDruid&comefrom=display&ts=1049772896)

InsaneDruid
26-03-04, 13:19
*Heimlich Posts schind*

nochmal ich.. also FSAA ist auch schon bei 2x und ohne AF ein "Workaround" um das Problem. Zumindest hier.

---
http://www.heidegrundschule.de/darksun/skinslogo.jpg (http://www.il2skins.com/?action=list&whereauthorid=InsaneDruid&comefrom=display&ts=1049772896)

InsaneDruid
26-03-04, 13:27
Letzter Post für Heute.. versprochen.. wie es aussieht benutzen Oleg&Co einen LineAA Algorithmus, umd die Linien auf der Map zu antialiasen. (warum auch immer) Das beißt sich wohl irgendwie mit den Treibern. Wenn man FSAA enabled scheints zu funzen.

---
http://www.heidegrundschule.de/darksun/skinslogo.jpg (http://www.il2skins.com/?action=list&whereauthorid=InsaneDruid&comefrom=display&ts=1049772896)

Neo-X-
26-03-04, 15:35
Da bin ich ja beruhigt dass andere das selbe Problem haben wie ich. Wollte nur bestätigen das 2xAA das Problem gut löst. Allerdings bei grenzwertigen FPS http://ubbxforums.ubi.com/images/smiley/16x16_smiley-sad.gif
(Cat 4.3 auf 9500Pro.., nur zur Info)

InsaneDruid
26-03-04, 17:57
Probier mal die 4.2 DLL zu benutzen, der 4.3er bricht unter perfect deutlich stärker ein als der 4.2

---
http://www.heidegrundschule.de/darksun/skinslogo.jpg (http://www.il2skins.com/?action=list&whereauthorid=InsaneDruid&comefrom=display&ts=1049772896)

VVS_Stone43
27-03-04, 00:23
Ich habe nur das IL2 FB und bei PERFECT den selben FEHLER!
Einen Tag kommt der Fehler nicht for,einen anderen Tag ist er beim Karten öffnen da,und bleibt dann auch.

Eine Lösung wäre hilfreich.
Ich habe eine Radeon 9600 Pro und alle Einstellungen durch,keinen Erfolg.

Vieleicht ist der Fehler mit dem Installieren des ACE ADDON weg?

frizz
27-03-04, 01:56
Also der Fehler ist erst seit ACE da. Hauptsächlich sternfömige Muster in Finnland und tritt auch wirklich regelmäßig auf (siehe untenals signature, weiß nicht wie man sonst Bild einfügt).
aber wie probiert man eine DLL, oder was ist FSAA...leider kann ich euch da nicht folgen. http://ubbxforums.ubi.com/images/smiley/351.gif

http://mitglied.lycos.de/frizz59/perfect.jpg

InsaneDruid
27-03-04, 03:44
Also.

FSAA: Full Screen Anti-Aliasing. Kantenglättung.
Um es anzuschalten (bei ATI): Eigenschaften von Anzeige->Einstellungen->Erweitert->3D(AtiSymbol)->OpenGL anwählen->Benutzerdefinierte Einstellungen verwenden->Button "Benutzerdefiniert" drücken.

Dann hast du ein Controlpanel "OpenGL Benutzerdefinierte Einstellungen" vor dir, mit mehreren Schiebereglern.

Wichtig sind die beiden obersten im Rahmen "Smoothvision 2.1"

Bei "Anti-Aliasing" den Haken "Standardeinstellung" wegnehmen, und im rechts danebenliegenden Slider die gewünschte Stärke der Kantenglättung einstellen. Um den Bug zu umgehen reicht dabei 2x, was auch das schnellste ist. 4x und 6x sehen besser aus, sind aber auch immer langsamer, wobei 4x auf 9800ern noch sehr gut zockbar ist, selbst 6x. Kann man ausprobieren.

Anisotropische Filterung kann man auch noch Einstellen (der Regler direkt darunter), auch wieder "Standardeinstellung" wegnehmen und am Regler die Stärke einstellen. Anisotropher Filter reduziert das Verwaschenwerden von schrägen Flächen in der Entfernung. Frisst aber auch recht Leistung. Zusätzlich kann man noch "Leistung" und "Qualität" umstellen. Am schnellsten ist aber "Standardeinstellung" (kein Anisotropher Filter)


DLLs testen:

Hier mal am Beispiel der Catalyst 4.2 dlls:

Man ziehst den Treiber, und anstatt ihn zu installieren (Doppelklick auf "wxp-w2k-catalyst-7-981-040127m-013420c.exe") öffnet man diese Datei mit Winrar (oder Winzip).
Also rechtsklick auf wxp-w2k-catalyst-7-981-040127m-013420c.exe ->Winrar->open with winrar.

In das Verzeichnis "Driver/2kxp_inf/b13529" wechseln, und die datei "atioglxx.dl_" an einen beliebigen ort extrahieren. (zb c:\). Winrar schließen.

Start->Ausführen aufrufen und "expand -r c:\*.dl_" eingeben. Eine datei "atioglxx.dll" wird generiert. Diese verschiebt/kopiert man nun in sein Il2 Verzeichnis. (dort wo auch die Il2.exe liegt).

Voila.. Il2 benutzt nun die OpenGL Treiber von Catalyst 4.2, auch wenn der Catalyst 4.3 installiert ist (für andere Spiele zb)

---
http://www.heidegrundschule.de/darksun/skinslogo.jpg (http://www.il2skins.com/?action=list&whereauthorid=InsaneDruid&comefrom=display&ts=1049772896)

frizz
27-03-04, 04:03
Ahh! Jetzt versteh ichs http://ubbxforums.ubi.com/images/smiley/16x16_smiley-very-happy.gif
werd ich gleich mal testen. Dankeschön

kubanloewe
27-03-04, 04:10
hm; absolut keine Probs hier; läuft wie ne eins sowohl das Game wie der Dell http://ubbxforums.ubi.com/infopop/emoticons/icon_biggrin.gif

http://home.arcor.de/kubanskiloewe/bf110comminghome.JPG

I.JG53_Steuben
27-03-04, 07:31
LOL was ist denn da fürn Meteor eingeschlagen http://ubbxforums.ubi.com/infopop/emoticons/icon_biggrin.gif

Dr.Drei
27-03-04, 07:44
Ich hab den Grafikfehler mit so ziemlich allen Catalyst Versionen http://ubbxforums.ubi.com/images/smiley/16x16_smiley-mad.gif

Ich probier mal das mit der Kantenglättung aus.

S!

II/JG26_Absinth.
Oberleutnant im Stabsschwarm, Co-Kommodore.

http://www.unet.univie.ac.at/~a9602140/il2/43.gif