PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Anno 2070 crashing on screen "calibrating planetary rotation"



Racou
29-12-12, 18:06
I'm really at the end of my patience at this moment. I've been waiting to buy this game for a long time. Finally, bought the more expensive deluxe version on Steam. I installed it, was able to log in and link my key. I was able click on the first screens learning who EVE is, the corps, etc. But if I try to start a campaign, a single mission, or ANYTHING...it gives me the windows "bonk" sound and dumps to desktop while thanking me for "playing." At first, I verified the steam cache files. 4 were corrupt so it fixed it. Problem persisted. Re-verified the steam cache and there was still one corrupt file. Now for the interesting part. I had steam redownload it about5 times. It simply couldn't verify that one file EVER and was always listed as corrupted. So I started researching the net for this issue. I've read that others have had this problem and called Ubisoft Customer Service. They told them to update their drivers. They did, called them back, and was told to "do it again."

So, I just spend 2 hours of my life downloading the most recent drivers to my motherboard BIOS, chipset, videocard, sound, usb, sata, LAN, and a couple others I probably can't remember. I did them ALL. As of 12.29.2012 EVERY driver is up to date from Asus's website (except nvidia and Intel Rapid Storage Technology drivers which had a more recent revision from the company's website).

Just tried it again, and it crashed again in the EXACT same manner.

My specs:
Win7 x64
Intel Core i7-3770K Ivy Bridge 3.5GHz (3.9GHz Turbo) LGA 1155 77W Quad-Core Desktop Processor
ASUS Maximus V EXTREME LGA 1155 Intel Z77 HDMI SATA 6Gb/s USB 3.0 Extended ATX Intel Motherboard
COOLER MASTER Silent Pro RSA00-AMBAJ3-US 1000W ATX12V v2.3 / EPS12V v2.92 SLI Ready 80 PLUS BRONZE Certified Modular
G.SKILL Ripjaws X Series 32GB (4 x 8GB) 240-Pin DDR3 SDRAM DDR3 1866 (PC3 14900) Desktop Memory Model F3-1866C10Q-32GXL
Galaxy 680 GTX 2 GB memory (also did this when using a 480 GTX but I just upgraded over X-mas).
SAMSUNG 830 Series MZ-7PC512B/WW 2.5" 512GB SATA III MLC Internal Solid State Drive (SSD) (system files)
SAMSUNG 840 Series MZ-7PC512B/WW 2.5" 500GB SATA III MLC Internal Solid State Drive (SSD) (game files)
NO RAID (if this matters)

Please continue reading because I really like Ubisoft but over the past few weeks they may forever lose me if this (and the following) issues can't be resolved.

Played AC3 on x-box no problems.
Bought FarCry 3, plays great but dumps to desktop and "thanks me for playing" just like Anno 2070 about 30-40 percent of the time I use fast travel.
Bought Ghost Recon: Future Soldier, crashed about 5 percent of time, just irritating but liveable without complaint
Really liked Ghost Recon Online, but crashes to desktop like Anno and FarCry 3 seconds after I join a match. Played my first match no problem, tabbed out to try to work on my sound settings to make sure my mic was selected. Tabbed back and game wasn't there (crashed), logged back in and now can't get back that first second when some kind of map is up and then it crashed to desktop and thanks me for playing.

I have MANY (1500) games on the PC. None of them really crash. This seems to be something SPECIFICALLY with Uplay. Also, whenever I log into a game, uplay can't see any of the other uplay games I have, which means I can't get the free/discount uplay deals over the holidays. Again, nothing but uplay frustration. Strangely, it does know my Name on each game (which is the same!).

I'm really at my wits end and need help. Any suggestions?

Thanks and sorry for this long post, but someone needs to address this as Ubisoft games appear to be broken for me and, based on specs and up-to-date drivers, this isn't understandable.

Take Care,

Racou