PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Schiffe bewegen sich ruckartig!



Judekw
16-05-12, 19:51
Hallo, bevor ich das im Thema erläuterte Problem im Bug-Forum nenne, wollte ich mal fragen, ob das auch anderen aufgefallen ist.

Problem: Schiffe, Flugzeuge, U-Boote bewegen sich allesamt ruckartig; bedeutet: sie fahren ein Stück, kurze Pause, fahren weiter usw. (die Pause ist dabei wirklich nur ein Bruchteil einer Sekunde, also wirklich kurz, sodass man denken könnte, die fps gehen in den Keller, was sie nicht tun, wie ich an flüssigen Bewegegungen im Hintergrund sehen konnte). Der Effekt fällt bei langsamen Einheiten nicht auf, bei schnellen Schiffen, die zusätzlich noch Upgrades haben allerdings wohl...

Ist zwar kein weltbewegender Fehler, stört aber den gesamten grafischen Eindruck, denn das Problem tritt offenbar leistungsunabhängig auf. Das ist zumindest meine These, deswegen wollte ich euch fragen, ob ihr dieses Problem auch habt! Am besten verfolgt ihr ein Schiff in der Postcardview (Einheit anklicken und F1 drücken) und haltet dann "-" gedrckt, dann fällt es auf jeden Fall auf :)

Vielen Dank, Judekw

KaptainRamon
16-05-12, 20:41
Ja,kann ich bestätigen.
Ist mir bisher nicht aufgefallen...

Mordred106
16-05-12, 20:52
Schließe mich an, eben getestet, kann ich auch bestätigen.

Das_Sternchen
16-05-12, 21:16
Ja, das is mir vorallem bei den Hovercrafts schon früher aufgefallen, wenn man die per Postkartenansicht verfolgt, war aber meines Wissens schon vor Patch 1.05 so.

semi_nonsens
16-05-12, 22:40
Bemerke ich auch nur in der Postkartenansicht.

Pc-Fan
16-05-12, 23:19
Stimmt, hatte ich vorher nicht bemerkt, also ich kanns bestätigen.

Judekw
16-05-12, 23:39
man merkt es daran, dass die schiffe sich im vergleich zu den beispielsweise dahinterliegenden kränen ruckartiger bewegen. vllt hängt es daran, dass ich meine schiffe meistens nur mit geschwindigkeitsitems aufrüste und der effekt so deutlicher wird. es stört mich allerdings, da man so keine vernünftigen filmchen im verfolgungsmodus drehen kann, was ja vorallem mit den schnellen flugzeugen in anno 2070 interessant wäre :)

edit: habe gerade noch mal kontrolliert und tatsächlich: das problem besteht nur in der postkartenansicht, sonst nicht.

@annogamer: ja du hast recht, das ist schon von beginn an so!

soerenseitz
05-01-13, 15:42
Ihr habt die Grafikeinstellungen zu hoch angesetzt.
Der PC schafft es nicht, das Bild so schnell zu berechnen, dass er so viele Bilder in einer Sekunde schafft, dass es euch als Film anstatt als Einzelbilder vorkommt. Beim menschl. Auge liegt diese Grenze - glaube ich - bei ca. 25 fps. Wenn ihr die Grafikeinst. heruntersetzt, muss der PC nicht so viel rechnen und schafft mehr als 25 fps.

DonJuseppe
06-01-13, 04:28
Willkommen im Forum,

der letzte Beitrag ist vom 16-05-12. Das Problem dürfte längst Geschichte sein :D

semi_nonsens
06-01-13, 19:20
Das Problem ist leider nicht Geschichte, DonJuseppe, doch man hatte dies ja auch schon in Anno 1404.

Judekw
07-01-13, 23:55
@soerenseits: daran hängt es definitiv nicht... die animationen im hintergrund sind flüssig, oben bereits beschrieben! erst lesen, dann den senf dazugeben ;D

G3nesiZ
08-01-13, 05:45
Nene, jetzt dürfen die Entwickler eine neue Engine schreiben das es in der Postkartenansischt nicht ruckelt!! HOPP :D Und nen Bug-Patch liefern se gleich hinterher, danköööö ;D

Judekw
09-01-13, 23:23
Ich schätze, man könnte das Problem auch mit einem Mod lösen, denn die Sprünge sind auch nur bei den Schiffen, denen die Kamera folgt, also nicht bei denen im Hintergrund... vermutlich treten diese Sprünge auf, sobald das zu verfolgende Objekt schneller ist als die Verfolgungsgeschwindigkeit der Kamera... habe aber leider noch nicht gefunden, wo letztere festgelegt ist :D

anno_heiho
10-01-13, 12:36
Hi,

das Problem gab es auch unter 1404.
Wenn ich mich noch richtig erinnere war es in der assets.xml --> irgendwas mit vehicle und winwalkspeed oder so ähnlich.
Evtl hilft es dir schon :D