PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Technikforum: Grafikeinstellung



stalker87
23-08-07, 15:22
hi leute habe ein problem.
ich kann bei meinen grafikeinstellungen die landschaftsdetails nicht auf perfekt stellen obwohl ich openGL verwende. kann mir einer helfen? hab eine geforc 8800gtx mit den aktuellsten treibern. danke im voraus

stalker87
23-08-07, 15:22
hi leute habe ein problem.
ich kann bei meinen grafikeinstellungen die landschaftsdetails nicht auf perfekt stellen obwohl ich openGL verwende. kann mir einer helfen? hab eine geforc 8800gtx mit den aktuellsten treibern. danke im voraus

Das_Morgoth
23-08-07, 15:30
bei der Auflösung nicht 16 bit sondern 32 bit einstellen ,Stencil Buffer an....

stalker87
24-08-07, 06:33
ja das dumme ist nur dass auch diese einstellungen an sind

KBSMarcAntonius
24-08-07, 08:59
Vergiss mal das Optionsmenü und nimm die Einstellungen direkt in der config.ini von IL-2 vor.

http://www.sturmovik.de/wiki/index.php?title=Conf.ini


Dazu für dich als G80 Besitzer noch diese DLL´s vpn Oleg - diese beseitigen einen Bug welcher bei den GTS und GTX auftrat.

http://files.games.1c.ru/il2pict/fix3.zip

stalker87
24-08-07, 11:02
also bei mir funktioniert die einstellung für das wasser nicht..das wasser hat immer noch keine wellen. die einstellung dafür in der config wurde auf bei openGL water=4 eingestellt. zwischen 3 und 4 hab ich keinen unterschied gesehen..das ist echt seltsam

KBSMarcAntonius
24-08-07, 13:23
Na stell mal deine ini so ein wie dort beschrieben - wichtig ist vor allem
HardwareShaders=1


Welchen Treiber nutzt du ?

stalker87
24-08-07, 13:47
ist eingestellt...komischerweise überschreibt das spiel die einstellung immer wieder sobald ich das gestartet hab. also wenn ich ausm spiel rausgehe sind die werte wieder so wie sie waren. treiber version 6.14.11.6218

KBSMarcAntonius
24-08-07, 13:53
Du darfst auf keinen Fall das Optionsmenü unter Windows oder im Spiel öffnen sonst wird alles überschrieben !



P.S. hier sind mal die neuen Treiber http://www.nzone.com/object/nzone_downloads_rel70betadriver.html

stalker87
24-08-07, 13:58
wenn es garnicht gehen sollte dann kann ich mich mitm wasser anfreunden. stellt sich nur die frage: wenn ich die landschaftsdetails auf perfekt stelle, hab ich dann auch automatisch eine größere sichtreichweite?

stalker87
24-08-07, 14:28
hmm was für gründe kann es sonst noch haben dass die perfekt einstellung grau hinterlegt ist?

KBSMarcAntonius
24-08-07, 17:25
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content"> wenn ich die landschaftsdetails auf perfekt stelle, hab ich dann auch automatisch eine größere sichtreichweite? </div></BLOCKQUOTE>+

Ja

Stuermchen
25-08-07, 05:28
Ich hatte vor ein paar Monaten das selbe Problem mit meiner x1800XT, hab aber dann einfach die Grafikeinstellungen auf max. gesetzt und nun läuft alles wunderbar und ich bin immer wieder aufs neue überrascht wie sensationell doch die Grafik in diesem Spiel ist in Verbindung mit einem 20" TFT mit S-IPS Panel und hoher Kantenglättung http://forums.ubi.com/images/smilies/heart.gif

MFG Manu

KG76_Bimmel
26-08-07, 04:10
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by stalker87:
hmm was für gründe kann es sonst noch haben dass die perfekt einstellung grau hinterlegt ist? </div></BLOCKQUOTE>

schau mal nach ob in der conf.ini unter "opengl" der Eintag "ForceShaders1x=0" auch auf Null steht!

stalker87
27-08-07, 12:35
ne steht auf 1 das ist es ja...selbst durch die config geht es nicht

KBSMarcAntonius
27-08-07, 14:13
Der muss aber auf 0 stehen !

Foo.bar
27-08-07, 14:31
Ich muss hier auch mal schnell eine Frage loswerden, da ich mit der x1950pro neuerdings in das ATI-Lager gewechselt bin:

sehe ich das richtig, dass man für ATI das beste (schönste) Wasser mit Water=2 bekommt?

Rinreiber
27-08-07, 14:49
Richtig Foo.bar! Für uns ATI User ist bei Water=2 Feierabend...

Foo.bar
27-08-07, 14:51
Na klasse http://forums.ubi.com/images/smilies/cry.gif 60 FPS in Perfekt bei 1600&times;1200 und plattes Wasser...

http://forums.ubi.com/images/smilies/16x16_smiley-very-happy.gif

Lehnert
27-08-07, 15:10
Hallo,
ich habe nur eine Nvidia 6800GT und deshalb nicht alle Einstellungen auf max.

Aber mit dieser folgenden Conf.ini läuft es im Perfect Mode.

Und nach manueller Änderung der Conf.ini nicht und niemals die IL2setup.exe laufen lassen !!

Habe im Wesentlichen hier nur die für Perfect relevanten Zeilen hier eingestellt.

il2]
title=Il2-Sturmovik Forgotten Battles
hotkeys=HotKey game

[window]
width=1280
height=1024
ColourBits=32
DepthBits=24
StencilBits=8
ChangeScreenRes=0
FullScreen=1
DrawIfNotFocused=0
EnableResize=0
EnableClose=1
SaveAspect=0
Use3Renders=0

[GLPROVIDER]
GL=Opengl32.dll

[GLPROVIDERS]
Open GL=Opengl32.dll
DirectX=dx8wrap.dll

......

....

[game]
Arcade=0
HighGore=1
mapPadX=0.66796875
mapPadY=0.41041666
viewSet=34
Intro=0
NoChatter=0
NoHudLog=0
NoLensFlare=1
iconTypes=3
eventlog=eventlog.lst
eventlogkeep=0
NoSubTitles=1
TypeClouds=0


[rts]
ProcessAffinityMask=1
mouseUse=2
joyUse=1
trackIRUse=0
DisableIME=0
locale=DE

[rts_mouse]
SensitivityX=1.0
SensitivityY=1.0
Invert=0
SensitivityZ=1.0


[Render_DirectX]
TexQual=3
TexMipFilter=2
TexCompress=0
TexFlags.UseDither=1
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=1
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=1
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=0
TexFlags.TexCompressARBExt=1
TexFlags.TexEnvCombine4NV=0
TexFlags.TexEnvCombineDot3=0
TexFlags.DepthClampNV=0
TexFlags.SeparateSpecular=0
TexFlags.TextureShaderNV=0

HardwareShaders=1

Shadows=2
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=2
Forest=2
LandShading=3
LandDetails=2

LandGeom=2
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=4
ForceShaders1x=0
PolygonOffsetFactor=-0.15
PolygonOffsetUnits=-3.0
Water=3
Effects=1

[Render_OpenGL]
TexQual=3
TexMipFilter=2
TexCompress=2
TexFlags.UseDither=0
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=0
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=1
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=1
TexFlags.TexCompressARBExt=1

TexFlags.TexEnvCombine4NV=1
TexFlags.TexEnvCombineDot3=1
TexFlags.DepthClampNV=1
TexFlags.SeparateSpecular=1
TexFlags.TextureShaderNV=1

HardwareShaders=1

Shadows=1
Specular=1
SpecularLight=1
DiffuseLight=1
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=2
Forest=2
LandShading=2
LandDetails=2

LandGeom=2
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=17
Water=3
Effects=1
ForceShaders1x=0
PolygonOffsetFactor=-0.15
PolygonOffsetUnits=-3.0

Viele Grüße
Gerhard



<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by stalker87:
hi leute habe ein problem.
ich kann bei meinen grafikeinstellungen die landschaftsdetails nicht auf perfekt stellen obwohl ich openGL verwende. kann mir einer helfen? hab eine geforc 8800gtx mit den aktuellsten treibern. danke im voraus </div></BLOCKQUOTE>

splindy
28-08-07, 09:14
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Foo.bar:
Na klasse http://forums.ubi.com/images/smilies/cry.gif 60 FPS in Perfekt bei 1600&times;1200 und plattes Wasser...

http://forums.ubi.com/images/smilies/16x16_smiley-very-happy.gif </div></BLOCKQUOTE>

Watt? Wie? 1950pro, water=2 und plattes Wasser?
Also bei mir bilden sich da (mieses Wetter vorausgesetzt) wunderbare Schaumkronen und kleine Wellenberge (x1950XTX).
Stell mal schlechtes Wetter ein, dann siehst du, was ich meine.

Gruß Splindy

Foo.bar
28-08-07, 09:33
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Stell mal schlechtes Wetter ein, dann siehst du, was ich meine. </div></BLOCKQUOTE>

http://www.ubisoft.de/smileys/bag.gif Bin bei schönstem Wetter geflogen...

Im Sturm sieht's sehr gut aus. Danke für den Zaunpfahl http://forums.ubi.com/images/smilies/16x16_smiley-very-happy.gif

stalker87
28-08-07, 10:56
sorry falsch verstanden..dieser steht natürlich auf 0

stalker87
28-08-07, 11:02
dieses hässliche spiel kotzt mich an !!!
die config so reinkopiert und wasser sieht immer noch aus wie sch...
und die einstellung perfekt ist immer noch grau hinterlegt. mit meiner 7800gtx hatte ich das problem nicht

Schuetz
28-08-07, 11:26
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Foo.bar:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Stell mal schlechtes Wetter ein, dann siehst du, was ich meine. </div></BLOCKQUOTE>

http://www.ubisoft.de/smileys/bag.gif Bin bei schönstem Wetter geflogen...

Im Sturm sieht's sehr gut aus. Danke für den Zaunpfahl http://forums.ubi.com/images/smilies/16x16_smiley-very-happy.gif </div></BLOCKQUOTE>
Wollte gerade sagen... http://forums.ubi.com/images/smilies/16x16_smiley-very-happy.gif

Foo.bar
28-08-07, 12:47
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">dieses hässliche spiel kotzt mich an !!! </div></BLOCKQUOTE>

Da redet jemand schlecht über unseren Lebensmittelpunkt. Ich glaube, da will jemand gebannt werden...

http://forums.ubi.com/images/smilies/16x16_smiley-very-happy.gif

stalker87
28-08-07, 16:04
haja ^^ das regt halt auf...aber ich zock trotzdem weiter auch wenns schlecht aussieht...bitte bitte ned bannen http://forums.ubi.com/images/smilies/11.gif

HuninMunin
28-08-07, 21:55
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Foo.bar:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">dieses hässliche spiel kotzt mich an !!! </div></BLOCKQUOTE>

Da redet jemand schlecht über unseren Lebensmittelpunkt. Ich glaube, da will jemand gebannt werden...

http://forums.ubi.com/images/smilies/16x16_smiley-very-happy.gif </div></BLOCKQUOTE>

http://forums.ubi.com/images/smilies/88.gif

der-blaue-max
29-08-07, 00:28
Ich würde IL-2 deinstallieren, den kompletten Ordner löschen!. Dann IL-2 neu instalieren!

Wenn das nicht hilft, stimmt was mit Deiner Karte oder deinem Betriebsystem/Treiber nicht!

Heba01
29-08-07, 01:28
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by stalker87:
dieses hässliche spiel kotzt mich an !!!
die config so reinkopiert und wasser sieht immer noch aus wie sch...
und die einstellung perfekt ist immer noch grau hinterlegt. mit meiner 7800gtx hatte ich das problem nicht </div></BLOCKQUOTE>

Dein Fehler war, Du hast die Einstellungen im Spiel überprüfen wollen. Das darfst Du nicht machen, damit springen die Einstellungen wieder zurück. Änder Deine Einstellungen nochmal in der config.ini und überprüfe das unter keinen Umständen im Spiel unter Hardware-Einstellungen!!!

Kirschen-Jaeger
29-08-07, 02:46
ein Trick ist auch bevor man IL2 startet nach dem Ändern der Conf.ini diese schreibzuschützen....

Rinreiber
29-08-07, 08:14
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Kirschen-Jaeger:
ein Trick ist auch bevor man IL2 startet nach dem Ändern der Conf.ini diese schreibzuschützen.... </div></BLOCKQUOTE>

Richtig! Oder, einfach nur "Datei speichern"... http://www.ubisoft.de/smileys/bag.gif

stalker87
01-09-07, 11:50
hat eigentlich sonst noch einer so ein problem wie ich gehabt?
wenn ja dann welche graka wurde eingesetzt?

stalker87
02-09-07, 09:56
wäre nett wenn sich mal einer melden würde der auch eine geforce 8800gtx hat.
kann man übrigens sonst noch irgendwo die shader "erzwingen"? weil wie schon erwähnt funktioniert bei mir das mit der config nicht.
gibt es vielleicht extra treiber für openGL?
und wo kann ich mich direkt zu den spiele entwickler mit meinem problem melden? den ich habe ned wirklich bock wegen il 2 mit eine andere graka kaufen zu müssen

Lehnert
03-09-07, 17:12
Hallo stalker87,
Ich habe keine Nvidia 8800 gtx

Aber das für Dich im US-Forum mittels "žFIND" Nvidia 8800 perfect
Gefunden.

Vielleicht hilft es Dir; insbesonders der Punkt 4 (sofern Du das nicht schon alles gemacht hast.....)

To use perfect mode, you must also turn on the stencil buffer, and run a 32 bit screen resolution. So, three things are needed:

1. OpenGL
2. 32 Bit resolution
3. Use Stencil Buffer

Wichtig :

4. In the Nvidia Control Panel, make sure 'Extension Limit' is switched off.


Then, Perfect landscape will be available.

Viele Grüße
Gerhard

Lehnert
05-09-07, 04:02
Hallo stalker87,
schon mal versucht mit "Extenison Limit = off" ??

Viele Grüße
Gerhard

stalker87
07-09-07, 11:03
sorry hatte bis jetzt nachtschicht...ich werde den versuch gleich starten..
ansonsten probier ich es noch mit c format http://forums.ubi.com/infopop/emoticons/icon_biggrin.gif
vielen dank

stalker87
08-09-07, 10:47
hi vielen dank..das lag an extension limit off.
endlich kann ich wieder in voller grafikprach von il 2 spielen http://forums.ubi.com/infopop/emoticons/icon_biggrin.gif
danke